summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-13 11:26:42 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-15 16:23:55 -0500
commit4e5c9f5851b4f353f2ee03a314fc7fb1f2e47398 (patch)
tree7aa67cbae224f373a3efaeaf49dbe8a0417785c9
parent799e98e2d1b6f50077041fd121cce17787edce35 (diff)
downloadmeta-cloud-services-4e5c9f5851b4f353f2ee03a314fc7fb1f2e47398.tar.gz
python-memcached: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-memcached.inc21
-rw-r--r--meta-openstack/recipes-devtools/python/python-memcached_git.bb23
-rw-r--r--meta-openstack/recipes-devtools/python/python3-memcached_git.bb2
3 files changed, 24 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-memcached.inc b/meta-openstack/recipes-devtools/python/python-memcached.inc
new file mode 100644
index 0000000..5acf43c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-memcached.inc
@@ -0,0 +1,21 @@
1SUMMARY = "Pure python memcached client"
2DESCRIPTION = "\
3 This software is a 100% Python interface to the memcached memory cache daemon. \
4 It is the client side software which allows storing values in one or more, possibly remote, \
5 memcached servers. Search google for memcached for more information."
6HOMEPAGE = "https://pypi.python.org/pypi/python-memcached/"
7SECTION = "devel/python"
8LICENSE = "PSF"
9LIC_FILES_CHKSUM = "file://PSF.LICENSE;md5=7dd786e8594f1e787da94a946557b40e"
10
11PV = "1.57+git${SRCPV}"
12SRCREV = "664bd3e23fe500fbde4c70636e2d24c8fd2f35af"
13
14SRC_URI = "git://github.com/linsomniac/python-memcached.git"
15
16S = "${WORKDIR}/git"
17
18RDEPENDS_${PN} += " \
19 ${PYTHON_PN}-six \
20 "
21
diff --git a/meta-openstack/recipes-devtools/python/python-memcached_git.bb b/meta-openstack/recipes-devtools/python/python-memcached_git.bb
index 9237af3..f237d56 100644
--- a/meta-openstack/recipes-devtools/python/python-memcached_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-memcached_git.bb
@@ -1,23 +1,2 @@
1SUMMARY = "Pure python memcached client" 1require python-memcached.inc
2DESCRIPTION = "\
3 This software is a 100% Python interface to the memcached memory cache daemon. \
4 It is the client side software which allows storing values in one or more, possibly remote, \
5 memcached servers. Search google for memcached for more information."
6HOMEPAGE = "https://pypi.python.org/pypi/python-memcached/"
7SECTION = "devel/python"
8LICENSE = "PSF"
9LIC_FILES_CHKSUM = "file://PSF.LICENSE;md5=7dd786e8594f1e787da94a946557b40e"
10
11PV = "1.57+git${SRCPV}"
12SRCREV = "664bd3e23fe500fbde4c70636e2d24c8fd2f35af"
13
14SRC_URI = "git://github.com/linsomniac/${BPN}.git"
15
16S = "${WORKDIR}/git"
17
18inherit setuptools 2inherit setuptools
19
20RDEPENDS_${PN} += " \
21 python-six \
22 "
23
diff --git a/meta-openstack/recipes-devtools/python/python3-memcached_git.bb b/meta-openstack/recipes-devtools/python/python3-memcached_git.bb
new file mode 100644
index 0000000..de96734
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-memcached_git.bb
@@ -0,0 +1,2 @@
1require python-memcached.inc
2inherit setuptools3