summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-13 12:47:46 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-15 16:23:55 -0500
commit799e98e2d1b6f50077041fd121cce17787edce35 (patch)
tree8d6f4460097275245ebf847b2f141ef7d6c06d1a
parent763406f58235a294fd5ed9f151741196251d450f (diff)
downloadmeta-cloud-services-799e98e2d1b6f50077041fd121cce17787edce35.tar.gz
python-pastedeploy: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-pastedeploy.inc16
-rw-r--r--meta-openstack/recipes-devtools/python/python-pastedeploy_2.0.1.bb18
-rw-r--r--meta-openstack/recipes-devtools/python/python3-pastedeploy_2.0.1.bb2
3 files changed, 20 insertions, 16 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pastedeploy.inc b/meta-openstack/recipes-devtools/python/python-pastedeploy.inc
new file mode 100644
index 0000000..db0b4ac
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pastedeploy.inc
@@ -0,0 +1,16 @@
1DESCRIPTION = "Load, configure, and compose WSGI applications and servers"
2HOMEPAGE = "http://pythonpaste.org/deploy/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=d6c3089319205d7e6129f0213b7e949f"
6
7PYPI_PACKAGE = "PasteDeploy"
8
9SRC_URI[md5sum] = "6193afccc0982abedb9b7711d0d6adb0"
10SRC_URI[sha256sum] = "d423fb9d51fdcf853aa4ff43ac7ec469b643ea19590f67488122d6d0d772350a"
11
12inherit pypi
13
14DEPENDS += "${PYTHON_PN}-pytest-runner-native"
15
16RDEPENDS_${PN} += "${PYTHON_PN}-paste"
diff --git a/meta-openstack/recipes-devtools/python/python-pastedeploy_2.0.1.bb b/meta-openstack/recipes-devtools/python/python-pastedeploy_2.0.1.bb
index 65668fa..8457858 100644
--- a/meta-openstack/recipes-devtools/python/python-pastedeploy_2.0.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-pastedeploy_2.0.1.bb
@@ -1,16 +1,2 @@
1DESCRIPTION = "Load, configure, and compose WSGI applications and servers" 1require python-pastedeploy.inc
2HOMEPAGE = "http://pythonpaste.org/deploy/" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=d6c3089319205d7e6129f0213b7e949f"
6
7PYPI_PACKAGE = "PasteDeploy"
8
9SRC_URI[md5sum] = "6193afccc0982abedb9b7711d0d6adb0"
10SRC_URI[sha256sum] = "d423fb9d51fdcf853aa4ff43ac7ec469b643ea19590f67488122d6d0d772350a"
11
12inherit setuptools pypi
13
14DEPENDS += "python-pytest-runner-native"
15
16RDEPENDS_${PN} += "python-paste"
diff --git a/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.0.1.bb b/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.0.1.bb
new file mode 100644
index 0000000..91c31a1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-pastedeploy_2.0.1.bb
@@ -0,0 +1,2 @@
1require python-pastedeploy.inc
2inherit setuptools3