summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-11-23 22:55:00 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-01 16:27:22 -0500
commit3c5c84590d661c3f0793da71020a306d4546c893 (patch)
treed3b02ddd26bffc6bddf32cb3adb7d55c4c8a578d
parent4520f75b1c7a1c0c5eed275b67d787fb0913dc42 (diff)
downloadmeta-cloud-services-3c5c84590d661c3f0793da71020a306d4546c893.tar.gz
python3-openstacksdk: Change to python3
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-openstacksdk_git.bb34
-rw-r--r--meta-openstack/recipes-devtools/python/python3-openstacksdk_git.bb41
2 files changed, 41 insertions, 34 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-openstacksdk_git.bb b/meta-openstack/recipes-devtools/python/python-openstacksdk_git.bb
deleted file mode 100644
index 3e52d0e..0000000
--- a/meta-openstack/recipes-devtools/python/python-openstacksdk_git.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1DESCRIPTION = "Unified SDK for OpenStack"
2HOMEPAGE = "https://github.com/openstack/python-openstacksdk"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7SRC_URI = " \
8 git://github.com/openstack/python-openstacksdk.git;branch=master \
9 "
10
11PV = "0.9.19+git${SRCPV}"
12SRCREV = "bd60aa4a21676b8901691298eb0786fc231f7bff"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += "\
18 python-pbr \
19 "
20
21# Satisfy setup.py 'setup_requires'
22DEPENDS += " \
23 python-pbr-native \
24 "
25
26RDEPENDS_${PN} += " \
27 python-pbr \
28 python-jsonpatch \
29 python-six \
30 python-stevedore \
31 python-os-client-config \
32 python-keystoneauth1 \
33 python-deprecation \
34 "
diff --git a/meta-openstack/recipes-devtools/python/python3-openstacksdk_git.bb b/meta-openstack/recipes-devtools/python/python3-openstacksdk_git.bb
new file mode 100644
index 0000000..7c14818
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-openstacksdk_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "Unified SDK for OpenStack"
2HOMEPAGE = "https://github.com/openstack/python-openstacksdk"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7SRC_URI = " \
8 git://github.com/openstack/python-openstacksdk.git;branch=master \
9 "
10
11PV = "0.52.0+git${SRCPV}"
12SRCREV = "e169c495de39a2d97ef1d8bb7894b18e4ef268dd"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += "\
18 python3-pbr \
19 "
20
21# Satisfy setup.py 'setup_requires'
22DEPENDS += " \
23 python3-pbr-native \
24 "
25
26RDEPENDS_${PN} += " \
27 python3-pbr \
28 bash \
29 python3-jsonpatch \
30 python3-six \
31 python3-stevedore \
32 python3-os-client-config \
33 python3-keystoneauth1 \
34 python3-deprecation \
35 python3-os-service-types \
36 python3-munch \
37 python3-jmespath \
38 python3-netifaces \
39 python3-decorator \
40 python3-dogpile.cache \
41 "