summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-11-23 23:00:19 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-01 16:27:22 -0500
commit4520f75b1c7a1c0c5eed275b67d787fb0913dc42 (patch)
tree878d9cd9db4ce3631b888302c600ca8acfb7da2b
parent93ccc3db29dbac229e6b16e9b25287e8634fcf1a (diff)
downloadmeta-cloud-services-4520f75b1c7a1c0c5eed275b67d787fb0913dc42.tar.gz
python3-salttesting: upgrade 2015.2.16 -> 2018.9.21
Refresh the following patch: 0001-Add-ptest-output-option-to-test-suite.patch Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-salttesting_2015.2.16.bb24
-rw-r--r--meta-openstack/recipes-devtools/python/python3-salttesting/0001-Add-ptest-output-option-to-test-suite.patch (renamed from meta-openstack/recipes-devtools/python/python-salttesting/0001-Add-ptest-output-option-to-test-suite.patch)24
-rw-r--r--meta-openstack/recipes-devtools/python/python3-salttesting_git.bb20
3 files changed, 33 insertions, 35 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-salttesting_2015.2.16.bb b/meta-openstack/recipes-devtools/python/python-salttesting_2015.2.16.bb
deleted file mode 100644
index d5d1e3e..0000000
--- a/meta-openstack/recipes-devtools/python/python-salttesting_2015.2.16.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "Common testing tools used in the Salt Stack projects"
2HOMEPAGE = "https://github.com/saltstack/salt-testing"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f36f1e9e3e30f90180efdf7e40d943e5"
6SRCNAME = "salt-testing"
7
8FILESEXTRAPATHS_append := "${THISDIR}/${PN}"
9
10SRC_URI = "https://github.com/saltstack/salt-testing/archive/v${PV}.tar.gz;downloadfilename=salt-testing-v${PV}.tar.gz \
11 file://0001-Add-ptest-output-option-to-test-suite.patch \
12 "
13SRC_URI[md5sum] = "8ca55a796e9ad7ba72bc143043753ccf"
14SRC_URI[sha256sum] = "0ef4be6a8a9b505ae1c328394dfad50493674af6100c7e2c220f374533d86edc"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18RDEPENDS_${PN} = "\
19 python-mock \
20 python-unittest \
21"
22
23inherit setuptools3
24
diff --git a/meta-openstack/recipes-devtools/python/python-salttesting/0001-Add-ptest-output-option-to-test-suite.patch b/meta-openstack/recipes-devtools/python/python3-salttesting/0001-Add-ptest-output-option-to-test-suite.patch
index e86768a..f1628a3 100644
--- a/meta-openstack/recipes-devtools/python/python-salttesting/0001-Add-ptest-output-option-to-test-suite.patch
+++ b/meta-openstack/recipes-devtools/python/python3-salttesting/0001-Add-ptest-output-option-to-test-suite.patch
@@ -1,6 +1,6 @@
1From 1950b943b7173198f345a1cff7b7f771cbac2244 Mon Sep 17 00:00:00 2001 1From 61ba63c3cde920873b8df48b950b8ebb79158346 Mon Sep 17 00:00:00 2001
2From: Collin Richards <collin.richards@ni.com> 2From: Wang Mingyu <wangmy@cn.fujitsu.com>
3Date: Tue, 28 Jun 2016 16:02:22 -0500 3Date: Thu, 19 Nov 2020 11:20:58 +0900
4Subject: [PATCH] Add ptest output option to test suite 4Subject: [PATCH] Add ptest output option to test suite
5 5
6Extend salttesting to support outputing the results of running the test 6Extend salttesting to support outputing the results of running the test
@@ -9,26 +9,28 @@ suite in ptest format.
9Upstream-Status: Inappropriate [OE specific] 9Upstream-Status: Inappropriate [OE specific]
10 10
11Signed-off-by: Collin Richards <collin.richards@ni.com> 11Signed-off-by: Collin Richards <collin.richards@ni.com>
12Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com>
13
12Natinst-ReviewBoard-ID: 143279 14Natinst-ReviewBoard-ID: 143279
13--- 15---
14 salttesting/parser/__init__.py | 12 +++ 16 salttesting/parser/__init__.py | 12 +++
15 salttesting/ptest.py | 165 +++++++++++++++++++++++++++++++++++++++++ 17 salttesting/ptest.py | 165 +++++++++++++++++++++++++++++++++
16 2 files changed, 177 insertions(+) 18 2 files changed, 177 insertions(+)
17 create mode 100644 salttesting/ptest.py 19 create mode 100644 salttesting/ptest.py
18 20
19diff --git a/salttesting/parser/__init__.py b/salttesting/parser/__init__.py 21diff --git a/salttesting/parser/__init__.py b/salttesting/parser/__init__.py
20index 1e7275b..d8cba0c 100644 22index d752acf..b41e5ea 100644
21--- a/salttesting/parser/__init__.py 23--- a/salttesting/parser/__init__.py
22+++ b/salttesting/parser/__init__.py 24+++ b/salttesting/parser/__init__.py
23@@ -25,6 +25,7 @@ from functools import partial 25@@ -28,6 +28,7 @@ from contextlib import closing
24 from contextlib import closing
25 26
27 import six
26 from salttesting import TestLoader, TextTestRunner 28 from salttesting import TestLoader, TextTestRunner
27+from salttesting.ptest import PTestRunner 29+from salttesting.ptest import PTestRunner
30 from salttesting import helpers
28 from salttesting.version import __version_info__ 31 from salttesting.version import __version_info__
29 from salttesting.xmlunit import HAS_XMLRUNNER, XMLTestRunner 32 from salttesting.xmlunit import HAS_XMLRUNNER, XMLTestRunner
30 try: 33@@ -277,6 +278,12 @@ class SaltTestingParser(optparse.OptionParser):
31@@ -264,6 +265,12 @@ class SaltTestingParser(optparse.OptionParser):
32 action='store_true', 34 action='store_true',
33 help='Do NOT show the overall tests result' 35 help='Do NOT show the overall tests result'
34 ) 36 )
@@ -41,7 +43,7 @@ index 1e7275b..d8cba0c 100644
41 self.add_option_group(self.output_options_group) 43 self.add_option_group(self.output_options_group)
42 44
43 self.fs_cleanup_options_group = optparse.OptionGroup( 45 self.fs_cleanup_options_group = optparse.OptionGroup(
44@@ -491,6 +498,11 @@ class SaltTestingParser(optparse.OptionParser): 46@@ -531,6 +538,11 @@ class SaltTestingParser(optparse.OptionParser):
45 verbosity=self.options.verbosity 47 verbosity=self.options.verbosity
46 ).run(tests) 48 ).run(tests)
47 self.testsuite_results.append((header, runner)) 49 self.testsuite_results.append((header, runner))
@@ -225,5 +227,5 @@ index 0000000..4c50f57
225+ self.stream.writeln() 227+ self.stream.writeln()
226+ return result 228+ return result
227-- 229--
2282.13.2 2302.25.1
229 231
diff --git a/meta-openstack/recipes-devtools/python/python3-salttesting_git.bb b/meta-openstack/recipes-devtools/python/python3-salttesting_git.bb
new file mode 100644
index 0000000..3447621
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-salttesting_git.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Common testing tools used in the Salt Stack projects"
2HOMEPAGE = "https://github.com/saltstack/salt-testing"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=f36f1e9e3e30f90180efdf7e40d943e5"
6
7SRC_URI = "git://github.com/saltstack/salt-testing.git;branch=develop;tag=v2018.9.21 \
8 file://0001-Add-ptest-output-option-to-test-suite.patch \
9 "
10
11PV = "2018.9.21+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15RDEPENDS_${PN} = "\
16 python3-mock \
17 python3-unittest \
18"
19
20inherit setuptools3