summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-10-20 14:41:36 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-27 23:27:51 -0400
commit2cde4d5c7d705b01936503e4a0550d1ffade70e7 (patch)
tree53a922c7c62944fd1f4ef20a3de47d7f8fb373dd
parentff02d6050d37f7e9ab95944362be64f28a57b6c3 (diff)
downloadmeta-cloud-services-2cde4d5c7d705b01936503e4a0550d1ffade70e7.tar.gz
python3-oslo.privsep: change to python3
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.privsep_git.bb (renamed from meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb)27
1 files changed, 13 insertions, 14 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.privsep_git.bb
index 463f95e..27da695 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.privsep_git.bb
@@ -5,32 +5,31 @@ LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6 6
7SRCNAME = "oslo.privsep" 7SRCNAME = "oslo.privsep"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike" 8SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
9 9
10PV = "1.22.1+git${SRCPV}" 10PV = "2.4.0+git${SRCPV}"
11SRCREV = "d27bb5371c90e0f8b1bdf1bc24f16e1532b3e595" 11SRCREV = "512b5d9f6b79b798474d8bb2dac2462b0f705cb9"
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14inherit setuptools3 14inherit setuptools3
15 15
16DEPENDS += " \ 16DEPENDS += " \
17 python-pbr \ 17 python3-pbr \
18 " 18 "
19 19
20# Satisfy setup.py 'setup_requires' 20# Satisfy setup.py 'setup_requires'
21DEPENDS += " \ 21DEPENDS += " \
22 python-pbr-native \ 22 python3-pbr-native \
23 " 23 "
24 24
25# RDEPENDS_default: 25# RDEPENDS_default:
26RDEPENDS_${PN} += " \ 26RDEPENDS_${PN} += " \
27 python-oslo.log \ 27 python3-oslo.log \
28 python-oslo.i18n \ 28 python3-oslo.i18n \
29 python-oslo.config \ 29 python3-oslo.config \
30 python-oslo.utils \ 30 python3-oslo.utils \
31 python-enum34 \ 31 python3-cffi \
32 python-cffi \ 32 python3-eventlet \
33 python-eventlet \ 33 python3-greenlet \
34 python-greenlet \ 34 python3-msgpack \
35 python-msgpack \
36 " 35 "