summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-oslo.privsep_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-oslo.privsep_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.privsep_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.privsep_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.privsep_git.bb
new file mode 100644
index 0000000..27da695
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.privsep_git.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "OpenStack library for privilege separation"
2HOMEPAGE = "https://github.com/openstack/oslo.privsep"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCNAME = "oslo.privsep"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
9
10PV = "2.4.0+git${SRCPV}"
11SRCREV = "512b5d9f6b79b798474d8bb2dac2462b0f705cb9"
12S = "${WORKDIR}/git"
13
14inherit setuptools3
15
16DEPENDS += " \
17 python3-pbr \
18 "
19
20# Satisfy setup.py 'setup_requires'
21DEPENDS += " \
22 python3-pbr-native \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 python3-oslo.log \
28 python3-oslo.i18n \
29 python3-oslo.config \
30 python3-oslo.utils \
31 python3-cffi \
32 python3-eventlet \
33 python3-greenlet \
34 python3-msgpack \
35 "