summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-10-20 14:42:18 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-27 23:27:51 -0400
commitff02d6050d37f7e9ab95944362be64f28a57b6c3 (patch)
tree465f5d166edca3fc4c8b0a4f29ac69970c745afa
parentb8245fa5a000f341f254df9d85b1e3ff3fb572ce (diff)
downloadmeta-cloud-services-ff02d6050d37f7e9ab95944362be64f28a57b6c3.tar.gz
python3-oslo.versionedobjects: change to python3
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.versionedobjects_git.bb41
-rw-r--r--meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb41
2 files changed, 41 insertions, 41 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.versionedobjects_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.versionedobjects_git.bb
deleted file mode 100644
index 16a57e1..0000000
--- a/meta-openstack/recipes-devtools/python/python-oslo.versionedobjects_git.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1DESCRIPTION = "oslo.versionedobjects library"
2HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PV = "1.26.0+git${SRCPV}"
8SRCREV = "78cd10662f20c4ae43e20a2dfa844cfd4e5cae26"
9
10SRCNAME = "oslo.versionedobjects"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python-pip \
19 python-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python-pbr-native \
25 "
26
27# RDEPENDS_default:
28RDEPENDS_${PN} += " \
29 python-six \
30 python-oslo.concurrency \
31 python-oslo.config \
32 python-oslo.context \
33 python-oslo.messaging \
34 python-oslo.serialization \
35 python-oslo.utils \
36 python-oslo.log \
37 python-oslo.i18n \
38 python-webob \
39 python-iso8601 \
40 python-netaddr \
41 "
diff --git a/meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb b/meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb
new file mode 100644
index 0000000..41064dd
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-oslo.versionedobjects_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "oslo.versionedobjects library"
2HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PV = "2.3.0+git${SRCPV}"
8SRCREV = "8db69628834332ed2df6690135be5d5c1ebd3ca1"
9
10SRCNAME = "oslo.versionedobjects"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 python3-pip \
19 python3-pbr \
20 "
21
22# Satisfy setup.py 'setup_requires'
23DEPENDS += " \
24 python3-pbr-native \
25 "
26
27# RDEPENDS_default:
28RDEPENDS_${PN} += " \
29 python3-six \
30 python3-oslo.concurrency \
31 python3-oslo.config \
32 python3-oslo.context \
33 python3-oslo.messaging \
34 python3-oslo.serialization \
35 python3-oslo.utils \
36 python3-oslo.log \
37 python3-oslo.i18n \
38 python3-webob \
39 python3-iso8601 \
40 python3-netaddr \
41 "