summaryrefslogtreecommitdiffstats
path: root/dynamic-layers
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-03-20 01:21:29 +0800
committerKhem Raj <raj.khem@gmail.com>2020-03-19 14:47:26 -0700
commitf76a6db1149842ee74de71323261c46470436239 (patch)
tree92d8d6639cdd8c2f8271a8e4260d9d2600283a02 /dynamic-layers
parent7653609ebfbeae0ef3f989aa62005e32b7835f48 (diff)
downloadmeta-clang-f76a6db1149842ee74de71323261c46470436239.tar.gz
bcc: include only when oe layer is available
Move bcc to dynamic-layers/openembedded-layer since it depends on luajit. Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Diffstat (limited to 'dynamic-layers')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch40
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb44
2 files changed, 84 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
new file mode 100644
index 0000000..4d71b15
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
@@ -0,0 +1,40 @@
1From cb3f032b55b32c50201862b26c76ea18ad37cb39 Mon Sep 17 00:00:00 2001
2From: Ovidiu Panait <ovidiu.panait@windriver.com>
3Date: Thu, 30 Jan 2020 14:19:33 +0200
4Subject: [PATCH] python/CMakeLists.txt: Remove check for host
5 /etc/debian_version
6
7Fix the following error that occurs during do_install when using the native
8version of python3:
9usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
10 or: setup.py --help [cmd1 cmd2 ...]
11 or: setup.py --help-commands
12 or: setup.py cmd --help
13
14error: option --install-layout not recognized
15
16Upstream-status: Innapropriate [oe-specific]
17
18Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
19---
20 src/python/CMakeLists.txt | 4 ----
21 1 file changed, 4 deletions(-)
22
23diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
24index fa602397..797e0d14 100644
25--- a/src/python/CMakeLists.txt
26+++ b/src/python/CMakeLists.txt
27@@ -5,10 +5,6 @@ if(NOT PYTHON_CMD)
28 set(PYTHON_CMD "python")
29 endif()
30
31-if(EXISTS "/etc/debian_version")
32- set(PYTHON_FLAGS "${PYTHON_FLAGS} --install-layout deb")
33-endif()
34-
35 file(GLOB_RECURSE PYTHON_SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
36 ${CMAKE_CURRENT_SOURCE_DIR}/*.py)
37 file(GLOB_RECURSE PYTHON_INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
38--
392.17.1
40
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb
new file mode 100644
index 0000000..115084e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb
@@ -0,0 +1,44 @@
1SUMMARY = "BPF Compiler Collection (BCC)"
2HOMEPAGE = "https://github.com/iovisor/bcc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
5
6inherit cmake python3native manpages
7
8DEPENDS += "bison-native \
9 flex-native \
10 elfutils \
11 luajit \
12 clang \
13 "
14
15RDEPENDS_${PN} += "bash python3 python3-core"
16
17SRC_URI = "gitsm://github.com/iovisor/bcc \
18 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
19 "
20
21SRCREV = "942227484d3207f6a42103674001ef01fb5335a0"
22
23S = "${WORKDIR}/git"
24
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
27
28EXTRA_OECMAKE = " \
29 -DENABLE_LLVM_SHARED=ON \
30 -DENABLE_CLANG_JIT=ON \
31 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \
32 -DPYTHON_CMD=${PYTHON} \
33 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \
34"
35
36do_install_append() {
37 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \
38 -i $(find ${D}${datadir}/${PN} -type f)
39}
40
41FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
42FILES_${PN}-doc += "${datadir}/${PN}/man"
43
44COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"