summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
new file mode 100644
index 0000000..4d71b15
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc/0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch
@@ -0,0 +1,40 @@
1From cb3f032b55b32c50201862b26c76ea18ad37cb39 Mon Sep 17 00:00:00 2001
2From: Ovidiu Panait <ovidiu.panait@windriver.com>
3Date: Thu, 30 Jan 2020 14:19:33 +0200
4Subject: [PATCH] python/CMakeLists.txt: Remove check for host
5 /etc/debian_version
6
7Fix the following error that occurs during do_install when using the native
8version of python3:
9usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
10 or: setup.py --help [cmd1 cmd2 ...]
11 or: setup.py --help-commands
12 or: setup.py cmd --help
13
14error: option --install-layout not recognized
15
16Upstream-status: Innapropriate [oe-specific]
17
18Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
19---
20 src/python/CMakeLists.txt | 4 ----
21 1 file changed, 4 deletions(-)
22
23diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
24index fa602397..797e0d14 100644
25--- a/src/python/CMakeLists.txt
26+++ b/src/python/CMakeLists.txt
27@@ -5,10 +5,6 @@ if(NOT PYTHON_CMD)
28 set(PYTHON_CMD "python")
29 endif()
30
31-if(EXISTS "/etc/debian_version")
32- set(PYTHON_FLAGS "${PYTHON_FLAGS} --install-layout deb")
33-endif()
34-
35 file(GLOB_RECURSE PYTHON_SOURCES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
36 ${CMAKE_CURRENT_SOURCE_DIR}/*.py)
37 file(GLOB_RECURSE PYTHON_INCLUDES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
38--
392.17.1
40