summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb
new file mode 100644
index 0000000..115084e
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/bcc/bcc_0.13.0.bb
@@ -0,0 +1,44 @@
1SUMMARY = "BPF Compiler Collection (BCC)"
2HOMEPAGE = "https://github.com/iovisor/bcc"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e3fc50a88d0a364313df4b21ef20c29e"
5
6inherit cmake python3native manpages
7
8DEPENDS += "bison-native \
9 flex-native \
10 elfutils \
11 luajit \
12 clang \
13 "
14
15RDEPENDS_${PN} += "bash python3 python3-core"
16
17SRC_URI = "gitsm://github.com/iovisor/bcc \
18 file://0001-python-CMakeLists.txt-Remove-check-for-host-etc-debi.patch \
19 "
20
21SRCREV = "942227484d3207f6a42103674001ef01fb5335a0"
22
23S = "${WORKDIR}/git"
24
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[manpages] = "-DENABLE_MAN=ON,-DENABLE_MAN=OFF,"
27
28EXTRA_OECMAKE = " \
29 -DENABLE_LLVM_SHARED=ON \
30 -DENABLE_CLANG_JIT=ON \
31 -DLLVM_PACKAGE_VERSION=${LLVMVERSION} \
32 -DPYTHON_CMD=${PYTHON} \
33 -DPYTHON_FLAGS=--install-lib=${PYTHON_SITEPACKAGES_DIR} \
34"
35
36do_install_append() {
37 sed -e 's@#!/usr/bin/python@#!/usr/bin/env python3@g' \
38 -i $(find ${D}${datadir}/${PN} -type f)
39}
40
41FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
42FILES_${PN}-doc += "${datadir}/${PN}/man"
43
44COMPATIBLE_HOST = "(x86_64.*|aarch64.*|powerpc64.*)-linux"