diff options
author | Max Krummenacher <max.krummenacher@toradex.com> | 2025-03-03 09:31:45 +0100 |
---|---|---|
committer | Rodrigo M. Duarte <rodrigo.duarte@ossystems.com.br> | 2025-03-31 17:06:06 -0300 |
commit | d96aff8e6a301c93639c23a8ccf198f44140223c (patch) | |
tree | c9cd5ed6f1f1b6d2afaa3ccbd32c35c99269ce9a /recipes-multimedia | |
parent | 9b53d8ac1d04f896466e7bfdcf5a6808e3f623c0 (diff) | |
download | meta-freescale-d96aff8e6a301c93639c23a8ccf198f44140223c.tar.gz |
imx-vpuwrap: fix build error
Add missing include file. Otherwise with latest master we see:
| ../git/vpu_wrapper_hantro_encoder.c:953:3: error: implicit declaration of function 'gettimeofday' [-Wimplicit-function-declaration]
| 953 | gettimeofday (&pObj->tvEnd, NULL);
Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch | 32 | ||||
-rw-r--r-- | recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb | 1 |
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch new file mode 100644 index 00000000..74ea5206 --- /dev/null +++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From a3c2f61649afd05e4bab457370f0b32d7644505c Mon Sep 17 00:00:00 2001 | ||
2 | From: Max Krummenacher <max.krummenacher@toradex.com> | ||
3 | Date: Mon, 3 Mar 2025 08:24:51 +0000 | ||
4 | Subject: [PATCH] vpu_wrapper_hantro_encoder: fix missing include | ||
5 | |||
6 | gettimeofday is declared in sys/time.h. Add the include. | ||
7 | |||
8 | Fixes the build error: | ||
9 | | ../git/vpu_wrapper_hantro_encoder.c:953:3: error: implicit declaration of function 'gettimeofday' [-Wimplicit-function-declaration] | ||
10 | | 953 | gettimeofday (&pObj->tvEnd, NULL); | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> | ||
14 | --- | ||
15 | vpu_wrapper_hantro_encoder.c | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/vpu_wrapper_hantro_encoder.c b/vpu_wrapper_hantro_encoder.c | ||
19 | index 3819c389320c..a0bdb2f4f6c0 100755 | ||
20 | --- a/vpu_wrapper_hantro_encoder.c | ||
21 | +++ b/vpu_wrapper_hantro_encoder.c | ||
22 | @@ -25,6 +25,7 @@ | ||
23 | #include <string.h> | ||
24 | #include <time.h> | ||
25 | #include <semaphore.h> | ||
26 | +#include <sys/time.h> | ||
27 | |||
28 | #include "headers/OMX_Video.h" | ||
29 | #include "headers/OMX_VideoExt.h" | ||
30 | -- | ||
31 | 2.42.0 | ||
32 | |||
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb index 86533c3c..de9b0daf 100644 --- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb +++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb | |||
@@ -12,6 +12,7 @@ DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc" | |||
12 | 12 | ||
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH} \ | 14 | git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH} \ |
15 | file://0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch \ | ||
15 | " | 16 | " |
16 | SRCBRANCH = "MM_04.09.02_2410_L6.6.y" | 17 | SRCBRANCH = "MM_04.09.02_2410_L6.6.y" |
17 | SRCREV = "378e33989cf72d6c2eb57a585072ba9abe87c6ff" | 18 | SRCREV = "378e33989cf72d6c2eb57a585072ba9abe87c6ff" |