summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch32
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch
new file mode 100644
index 00000000..74ea5206
--- /dev/null
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap/0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch
@@ -0,0 +1,32 @@
1From a3c2f61649afd05e4bab457370f0b32d7644505c Mon Sep 17 00:00:00 2001
2From: Max Krummenacher <max.krummenacher@toradex.com>
3Date: Mon, 3 Mar 2025 08:24:51 +0000
4Subject: [PATCH] vpu_wrapper_hantro_encoder: fix missing include
5
6gettimeofday is declared in sys/time.h. Add the include.
7
8Fixes the build error:
9| ../git/vpu_wrapper_hantro_encoder.c:953:3: error: implicit declaration of function 'gettimeofday' [-Wimplicit-function-declaration]
10| 953 | gettimeofday (&pObj->tvEnd, NULL);
11
12Upstream-Status: Pending
13Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
14---
15 vpu_wrapper_hantro_encoder.c | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/vpu_wrapper_hantro_encoder.c b/vpu_wrapper_hantro_encoder.c
19index 3819c389320c..a0bdb2f4f6c0 100755
20--- a/vpu_wrapper_hantro_encoder.c
21+++ b/vpu_wrapper_hantro_encoder.c
22@@ -25,6 +25,7 @@
23 #include <string.h>
24 #include <time.h>
25 #include <semaphore.h>
26+#include <sys/time.h>
27
28 #include "headers/OMX_Video.h"
29 #include "headers/OMX_VideoExt.h"
30--
312.42.0
32
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
index 86533c3c..de9b0daf 100644
--- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
@@ -12,6 +12,7 @@ DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc"
12 12
13SRC_URI = " \ 13SRC_URI = " \
14 git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH} \ 14 git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH} \
15 file://0001-vpu_wrapper_hantro_encoder-fix-missing-include.patch \
15" 16"
16SRCBRANCH = "MM_04.09.02_2410_L6.6.y" 17SRCBRANCH = "MM_04.09.02_2410_L6.6.y"
17SRCREV = "378e33989cf72d6c2eb57a585072ba9abe87c6ff" 18SRCREV = "378e33989cf72d6c2eb57a585072ba9abe87c6ff"