summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/debianutils
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/debianutils')
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.11.2.bb55
-rw-r--r--meta/recipes-support/debianutils/debianutils_5.17.bb58
2 files changed, 58 insertions, 55 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.11.2.bb b/meta/recipes-support/debianutils/debianutils_4.11.2.bb
deleted file mode 100644
index 0eeb2954f7..0000000000
--- a/meta/recipes-support/debianutils/debianutils_4.11.2.bb
+++ /dev/null
@@ -1,55 +0,0 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SECTION = "base"
3LICENSE = "GPLv2 & SMAIL_GPL"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=9b912cd0cc654134c0ef3424a0705b94"
5
6SRC_URI = "http://snapshot.debian.org/archive/debian/20200929T025235Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
7# the package is taken from snapshots.debian.org; that source is static and goes stale
8# so we check the latest upstream from a directory that does get updated
9UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
10
11SRC_URI[sha256sum] = "3b680e81709b740387335fac8f8806d71611dcf60874e1a792e862e48a1650de"
12
13inherit autotools update-alternatives
14
15S = "${WORKDIR}/debianutils"
16do_configure_prepend() {
17 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
18}
19
20do_install_append() {
21 if [ "${base_bindir}" != "${bindir}" ]; then
22 # Debian places some utils into ${base_bindir} as does busybox
23 install -d ${D}${base_bindir}
24 for app in run-parts tempfile; do
25 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
26 done
27 fi
28}
29
30# Note that we package the update-alternatives name.
31#
32PACKAGES =+ "${PN}-run-parts"
33FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
34
35RDEPENDS_${PN} += "${PN}-run-parts"
36RDEPENDS_${PN}_class-native = ""
37
38ALTERNATIVE_PRIORITY = "30"
39ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
40
41ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
42ALTERNATIVE_${PN}-run-parts = "run-parts"
43
44ALTERNATIVE_${PN}-doc = "which.1"
45ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
46
47ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell"
48ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
49ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell"
50ALTERNATIVE_LINK_NAME[run-parts] = "${base_bindir}/run-parts"
51ALTERNATIVE_LINK_NAME[savelog] = "${bindir}/savelog"
52ALTERNATIVE_LINK_NAME[tempfile] = "${base_bindir}/tempfile"
53ALTERNATIVE_LINK_NAME[which] = "${bindir}/which"
54
55BBCLASSEXTEND = "native"
diff --git a/meta/recipes-support/debianutils/debianutils_5.17.bb b/meta/recipes-support/debianutils/debianutils_5.17.bb
new file mode 100644
index 0000000000..c5f25bae40
--- /dev/null
+++ b/meta/recipes-support/debianutils/debianutils_5.17.bb
@@ -0,0 +1,58 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2DESCRIPTION = "Provides a number of small utilities which are used \
3primarily by the installation scripts of Debian packages, although \
4you may use them directly. "
5HOMEPAGE = "https://packages.debian.org/sid/debianutils"
6BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=debianutils;dist=unstable"
7SECTION = "base"
8LICENSE = "GPL-2.0-only & SMAIL_GPL"
9LIC_FILES_CHKSUM = "file://debian/copyright;md5=4b667f30411d21bc8fd7db85d502a8e9"
10
11SRC_URI = "git://salsa.debian.org/debian/debianutils.git;protocol=https;branch=master \
12 "
13
14SRCREV = "baf12e98a02883d1b76081e32f2185ee3497570b"
15
16inherit autotools update-alternatives
17
18S = "${WORKDIR}/git"
19
20# Disable po4a (translated manpages) sub-directory, as that requires po4a to build
21do_configure:prepend() {
22 sed -i -e 's:po4a::g' ${S}/Makefile.am
23}
24
25
26do_install:append() {
27 if [ "${base_bindir}" != "${bindir}" ]; then
28 # Debian places some utils into ${base_bindir} as does busybox
29 install -d ${D}${base_bindir}
30 for app in run-parts; do
31 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
32 done
33 fi
34 mv ${D}${bindir}/which.debianutils ${D}${bindir}/which
35}
36
37# Note that we package the update-alternatives name.
38#
39PACKAGES =+ "${PN}-run-parts"
40FILES:${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
41
42RDEPENDS:${PN} += "${PN}-run-parts"
43RDEPENDS:${PN}:class-native = ""
44
45ALTERNATIVE_PRIORITY = "30"
46ALTERNATIVE:${PN} = "add-shell installkernel remove-shell savelog which"
47
48ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
49ALTERNATIVE:${PN}-run-parts = "run-parts"
50
51ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell"
52ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
53ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell"
54ALTERNATIVE_LINK_NAME[run-parts] = "${base_bindir}/run-parts"
55ALTERNATIVE_LINK_NAME[savelog] = "${bindir}/savelog"
56ALTERNATIVE_LINK_NAME[which] = "${bindir}/which"
57
58BBCLASSEXTEND = "native"