summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/debianutils/debianutils_4.11.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/debianutils/debianutils_4.11.2.bb')
-rw-r--r--meta/recipes-support/debianutils/debianutils_4.11.2.bb55
1 files changed, 0 insertions, 55 deletions
diff --git a/meta/recipes-support/debianutils/debianutils_4.11.2.bb b/meta/recipes-support/debianutils/debianutils_4.11.2.bb
deleted file mode 100644
index 0eeb2954f7..0000000000
--- a/meta/recipes-support/debianutils/debianutils_4.11.2.bb
+++ /dev/null
@@ -1,55 +0,0 @@
1SUMMARY = "Miscellaneous utilities specific to Debian"
2SECTION = "base"
3LICENSE = "GPLv2 & SMAIL_GPL"
4LIC_FILES_CHKSUM = "file://debian/copyright;md5=9b912cd0cc654134c0ef3424a0705b94"
5
6SRC_URI = "http://snapshot.debian.org/archive/debian/20200929T025235Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
7# the package is taken from snapshots.debian.org; that source is static and goes stale
8# so we check the latest upstream from a directory that does get updated
9UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
10
11SRC_URI[sha256sum] = "3b680e81709b740387335fac8f8806d71611dcf60874e1a792e862e48a1650de"
12
13inherit autotools update-alternatives
14
15S = "${WORKDIR}/debianutils"
16do_configure_prepend() {
17 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
18}
19
20do_install_append() {
21 if [ "${base_bindir}" != "${bindir}" ]; then
22 # Debian places some utils into ${base_bindir} as does busybox
23 install -d ${D}${base_bindir}
24 for app in run-parts tempfile; do
25 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
26 done
27 fi
28}
29
30# Note that we package the update-alternatives name.
31#
32PACKAGES =+ "${PN}-run-parts"
33FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
34
35RDEPENDS_${PN} += "${PN}-run-parts"
36RDEPENDS_${PN}_class-native = ""
37
38ALTERNATIVE_PRIORITY = "30"
39ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
40
41ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
42ALTERNATIVE_${PN}-run-parts = "run-parts"
43
44ALTERNATIVE_${PN}-doc = "which.1"
45ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
46
47ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell"
48ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
49ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell"
50ALTERNATIVE_LINK_NAME[run-parts] = "${base_bindir}/run-parts"
51ALTERNATIVE_LINK_NAME[savelog] = "${bindir}/savelog"
52ALTERNATIVE_LINK_NAME[tempfile] = "${base_bindir}/tempfile"
53ALTERNATIVE_LINK_NAME[which] = "${bindir}/which"
54
55BBCLASSEXTEND = "native"