summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.73.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.73.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.73.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.73.0.bb b/meta/recipes-support/boost/bjam-native_1.73.0.bb
new file mode 100644
index 0000000000..d843eb038c
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.73.0.bb
@@ -0,0 +1,20 @@
1require boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
9 file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
10 "
11
12do_compile() {
13 ./bootstrap.sh --with-toolset=gcc
14}
15
16do_install() {
17 install -d ${D}${bindir}/
18 # install unstripped version for bjam
19 install -c -m 755 b2 ${D}${bindir}/bjam
20}