summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.73.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-05-23 02:23:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-24 23:56:03 +0100
commita28c4978ebfd4b2928ee8beeeabdc9fa631cb619 (patch)
tree7bc5f8befd3746b66a4a5284b760fb2dcfd458ae /meta/recipes-support/boost/bjam-native_1.73.0.bb
parent945cf5f02a6bba194c658e66ad5699569415db99 (diff)
downloadpoky-a28c4978ebfd4b2928ee8beeeabdc9fa631cb619.tar.gz
boost: upgrade 1.72.0 -> 1.73.0
refresh 0001-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch remove 0001-revert-cease-dependence-on-range.patch since it is included in 1.73.0 (From OE-Core rev: 1728ecf71f96570913202a54fd0012ac8b01b8ae) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.73.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.73.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.73.0.bb b/meta/recipes-support/boost/bjam-native_1.73.0.bb
new file mode 100644
index 0000000000..d843eb038c
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.73.0.bb
@@ -0,0 +1,20 @@
1require boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
9 file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
10 "
11
12do_compile() {
13 ./bootstrap.sh --with-toolset=gcc
14}
15
16do_install() {
17 install -d ${D}${bindir}/
18 # install unstripped version for bjam
19 install -c -m 755 b2 ${D}${bindir}/bjam
20}