summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.5.1.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.5.1.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.5.1.bb b/meta/recipes-multimedia/libtiff/tiff_4.5.1.bb
new file mode 100644
index 0000000000..5af3f84265
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.5.1.bb
@@ -0,0 +1,61 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz"
12
13SRC_URI[sha256sum] = "d7f38b6788e4a8f5da7940c5ac9424f494d8a79eba53d555f4a507167dca5e2b"
14
15# exclude betas
16UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
17
18# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
19# and 4.3.0 doesn't have the issue
20CVE_CHECK_IGNORE += "CVE-2015-7313"
21
22inherit autotools multilib_header
23
24CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
25
26PACKAGECONFIG ?= "cxx jpeg zlib lzma \
27 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
28
29PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
30PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
31PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
32PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
33PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
34PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
35PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
36PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
37
38# Convert single-strip uncompressed images to multiple strips of specified
39# size (default: 8192) to reduce memory usage
40PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
41
42# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
43PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
44
45# Control picking up YCbCr subsample info. Disable to support files lacking
46# the tag
47PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
48
49# Support a mechanism allowing reading large strips (usually one strip files)
50# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
51PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
52
53PACKAGES =+ "tiffxx tiff-utils"
54FILES:tiffxx = "${libdir}/libtiffxx.so.*"
55FILES:tiff-utils = "${bindir}/*"
56
57do_install:append() {
58 oe_multilib_header tiffconf.h
59}
60
61BBCLASSEXTEND = "native nativesdk"