summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb
new file mode 100644
index 0000000000..83bc6877d2
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb
@@ -0,0 +1,46 @@
1SUMMARY = "ALSA sound library"
2DESCRIPTION = "(Occasionally a.k.a. libasound) is a userspace library that \
3provides a level of abstraction over the /dev interfaces provided by the kernel modules."
4HOMEPAGE = "http://www.alsa-project.org"
5BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
6SECTION = "libs/multimedia"
7LICENSE = "LGPL-2.1-only & GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7 \
9 file://src/socket.c;md5=285675b45e83f571c6a957fe4ab79c93;beginline=9;endline=24 \
10 "
11
12SRC_URI = "https://www.alsa-project.org/files/pub/lib/${BP}.tar.bz2 \
13 file://0001-global.h-move-__STRING-macro-outside-PIC-ifdef-block.patch \
14 "
15SRC_URI[sha256sum] = "c86a45a846331b1b0aa6e6be100be2a7aef92efd405cf6bac7eef8174baa920e"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF += " \
20 ${@bb.utils.contains('TARGET_FPU', 'soft', '--with-softfloat', '', d)} \
21 --disable-python --disable-old-symbols \
22"
23
24PACKAGES =+ "alsa-server alsa-conf libatopology"
25
26FILES:alsa-server = "${bindir}/*"
27FILES:alsa-conf = "${datadir}/alsa/"
28FILES:libatopology = "${libdir}/libatopology.so.*"
29
30RDEPENDS:${PN}:class-target = "alsa-conf alsa-ucm-conf"
31RDEPENDS:libatopology:class-target = "alsa-topology-conf"
32
33# upgrade path
34RPROVIDES:${PN} = "libasound"
35RREPLACES:${PN} = "libasound"
36RCONFLICTS:${PN} = "libasound"
37
38RPROVIDES:${PN}-dev = "alsa-dev"
39RREPLACES:${PN}-dev = "alsa-dev"
40RCONFLICTS:${PN}-dev = "alsa-dev"
41
42RPROVIDES:alsa-conf = "alsa-conf-base"
43RREPLACES:alsa-conf = "alsa-conf-base"
44RCONFLICTS:alsa-conf = "alsa-conf-base"
45
46BBCLASSEXTEND = "native nativesdk"