summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb
diff options
context:
space:
mode:
authorMichael Opdenacker <michael.opdenacker@bootlin.com>2023-09-19 13:53:19 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-20 08:57:27 +0100
commitebcf25b14f934fbd323a381604d0727a544fd4db (patch)
tree5ad56a0e1957fcd4e961fd47cc7dede64ff7efea /meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb
parent6d7af50f88d26d80e1a2d99758bdfc811c41644d (diff)
downloadpoky-ebcf25b14f934fbd323a381604d0727a544fd4db.tar.gz
alsa-lib: upgrade 1.2.9 -> 1.2.10
Changelog: - Fix symver build error on non-ELF platforms - ucm: main - remove cast to pointer from integer of different size warning - ucm: mark internal functions static - topology: fix src/mixer/mixer.c return value warning - dogyxen: fix topology.h warnings - doxygen: fix broken examples links - doxygen: include docs for shmarea functions - doxygen: conf: do not hide PCM specific function - doxygen: silence warning from asoundlib.h - doxygen: ucm: silence warnings - doxygen: topology: silence 'not documented' warnings - doxygen: global: silence 'not documented' warnings - doxygen: namehint: silence 'not documented' warnings - doxygen: seq: silence 'not documented' warnings - doxygen: conf: silence 'not documented' warnings - doxygen: rawmidi: silence 'not documented' warnings - doxygen: control: silence 'not documented' item warnings - doxygen: pcm: silence 'not documented' warnings - doxygen: include external control docs - doxygen: fix inadvertent link requests - doxygen: fix list indentation errors - doxygen: escape xml tags - doxygen: fix image path - doxygen: fix broken parameter name tags - doxygen: Fix missing group end markers - reshuffle included files to include config.h as first - configure: add AC_SYS_LARGEFILE - seq: Fix wrong seq version update at snd_seq_hw_get_client_info() - seq: Add overflow check in snd_seq_ev_set_ump_data() - test: oldapi - fix the clang-16 compilation error - rawmidi: Suppress error messages for non-fatal errors - seq: ump: Fix typo in function name containing "group" - pcm: hw: fix minor bug in sw_params ioctl - seq: Add UMP 1.1 features - ump: Add UMP 1.1 features - uapi: Update rawmidi API to 2.0.4 - seq: Add UMP support - uapi: Update asequencer.h definitions for 1.0.3 - ump: Add helpers for handling SysEx data - ump: Add helpers to parse / set UMP packet data - control: Add UMP Endpoint and Block info query support - control: Add UMP device query support -- ump: Add initial support - rawmidi: Add UMP ioctl support - uapi: Update control API to 2.0.9 - uapi: Update rawmidi API to 2.0.3 - remove extra trailing new line in SNDMSG and SNDERR calls - usecase: add CaptureMicInfoFile field to documentation - include: fix SND_DLSYM_BUILD_VERSION() for static build - pcm: hw - prevent divide by zero for broken apps (From OE-Core rev: 232b6b7276b6b34edd1aa5292897a92e16235ecf) Signed-off-by: Michael Opdenacker <michael.opdenacker@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb
new file mode 100644
index 0000000000..83bc6877d2
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.2.10.bb
@@ -0,0 +1,46 @@
1SUMMARY = "ALSA sound library"
2DESCRIPTION = "(Occasionally a.k.a. libasound) is a userspace library that \
3provides a level of abstraction over the /dev interfaces provided by the kernel modules."
4HOMEPAGE = "http://www.alsa-project.org"
5BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
6SECTION = "libs/multimedia"
7LICENSE = "LGPL-2.1-only & GPL-2.0-or-later"
8LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7 \
9 file://src/socket.c;md5=285675b45e83f571c6a957fe4ab79c93;beginline=9;endline=24 \
10 "
11
12SRC_URI = "https://www.alsa-project.org/files/pub/lib/${BP}.tar.bz2 \
13 file://0001-global.h-move-__STRING-macro-outside-PIC-ifdef-block.patch \
14 "
15SRC_URI[sha256sum] = "c86a45a846331b1b0aa6e6be100be2a7aef92efd405cf6bac7eef8174baa920e"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF += " \
20 ${@bb.utils.contains('TARGET_FPU', 'soft', '--with-softfloat', '', d)} \
21 --disable-python --disable-old-symbols \
22"
23
24PACKAGES =+ "alsa-server alsa-conf libatopology"
25
26FILES:alsa-server = "${bindir}/*"
27FILES:alsa-conf = "${datadir}/alsa/"
28FILES:libatopology = "${libdir}/libatopology.so.*"
29
30RDEPENDS:${PN}:class-target = "alsa-conf alsa-ucm-conf"
31RDEPENDS:libatopology:class-target = "alsa-topology-conf"
32
33# upgrade path
34RPROVIDES:${PN} = "libasound"
35RREPLACES:${PN} = "libasound"
36RCONFLICTS:${PN} = "libasound"
37
38RPROVIDES:${PN}-dev = "alsa-dev"
39RREPLACES:${PN}-dev = "alsa-dev"
40RCONFLICTS:${PN}-dev = "alsa-dev"
41
42RPROVIDES:alsa-conf = "alsa-conf-base"
43RREPLACES:alsa-conf = "alsa-conf-base"
44RCONFLICTS:alsa-conf = "alsa-conf-base"
45
46BBCLASSEXTEND = "native nativesdk"