diff options
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20240827.bb')
-rw-r--r-- | meta/recipes-extended/acpica/acpica_20240827.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20240827.bb b/meta/recipes-extended/acpica/acpica_20240827.bb new file mode 100644 index 0000000000..7e8c68db90 --- /dev/null +++ b/meta/recipes-extended/acpica/acpica_20240827.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" | ||
2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ | ||
3 | OS-independent reference implementation of the Advanced Configuration and \ | ||
4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ | ||
5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ | ||
6 | subsystem, and a small set of tools to assist in developing and debugging \ | ||
7 | ACPI tables." | ||
8 | |||
9 | HOMEPAGE = "https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html" | ||
10 | SECTION = "console/tools" | ||
11 | |||
12 | LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only" | ||
13 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=05eb845b15a27440410f456adc2ed082" | ||
14 | |||
15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | ||
16 | |||
17 | DEPENDS = "m4-native flex-native bison-native" | ||
18 | |||
19 | SRC_URI = "git://github.com/acpica/acpica;protocol=https;branch=master" | ||
20 | SRCREV = "e80cbd7b52de20aa8c75bfba9845e9cb61f2e681" | ||
21 | |||
22 | S = "${WORKDIR}/git" | ||
23 | |||
24 | inherit update-alternatives | ||
25 | |||
26 | ALTERNATIVE_PRIORITY = "100" | ||
27 | ALTERNATIVE:${PN} = "acpixtract acpidump" | ||
28 | |||
29 | EXTRA_OEMAKE = "CC='${CC}' \ | ||
30 | OPT_CFLAGS=-Wall \ | ||
31 | DESTDIR=${D} \ | ||
32 | PREFIX=${prefix} \ | ||
33 | INSTALLDIR=${bindir} \ | ||
34 | INSTALLFLAGS= \ | ||
35 | YACC=bison \ | ||
36 | YFLAGS='-y --file-prefix-map=${WORKDIR}=${TARGET_DBGSRC_DIR}' \ | ||
37 | " | ||
38 | |||
39 | do_install() { | ||
40 | oe_runmake install | ||
41 | } | ||
42 | |||
43 | # iasl*.bb is a subset of this recipe, so RREPLACE it | ||
44 | PROVIDES = "iasl" | ||
45 | RPROVIDES:${PN} += "iasl" | ||
46 | RREPLACES:${PN} += "iasl" | ||
47 | RCONFLICTS:${PN} += "iasl" | ||
48 | |||
49 | BBCLASSEXTEND = "native nativesdk" | ||