summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/acpica_20240827.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-09-03 16:32:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-09-04 12:38:44 +0100
commitf48465f04c8678b5431e98386b7de744d030da4e (patch)
treeef19ce3da0293d93c0b15a0196c66905a49ed5fc /meta/recipes-extended/acpica/acpica_20240827.bb
parentce383483f203b99c1ca4807947e07a5d96bcabce (diff)
downloadpoky-f48465f04c8678b5431e98386b7de744d030da4e.tar.gz
acpica: upgrade 20240322 -> 20240827
Changelog: ========== - Fix the PHAT table working: ensure that the PHAT firmware health record offset works correctly, fix various sub-table offsets, prevent segmentation faults when encountering invalid device paths. - Fix the optional table 4-byte signature. - Correct the dumping of SLIC and DBG2 tables. - Add support for QWordPCC and DWordPCC - Fix the integer to hex string conversions - Detecting FACS in reduced HW mode and allowing setting waking vector thereby waking up from S3 state - Fixing issues with crossing page boundaries when mapping operation regions - Update the support for IORT, HMAT, MPAM, AEST, CEDT, SPCR etc. tables - Fix multiple issues with table parsing, compilation and disassembly - Allow for more flexibility in _DSM usage. (From OE-Core rev: d1271e6435a399094152ceac540e160d87d7ae3b) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20240827.bb')
-rw-r--r--meta/recipes-extended/acpica/acpica_20240827.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20240827.bb b/meta/recipes-extended/acpica/acpica_20240827.bb
new file mode 100644
index 0000000000..7e8c68db90
--- /dev/null
+++ b/meta/recipes-extended/acpica/acpica_20240827.bb
@@ -0,0 +1,49 @@
1SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
9HOMEPAGE = "https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html"
10SECTION = "console/tools"
11
12LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only"
13LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=05eb845b15a27440410f456adc2ed082"
14
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "m4-native flex-native bison-native"
18
19SRC_URI = "git://github.com/acpica/acpica;protocol=https;branch=master"
20SRCREV = "e80cbd7b52de20aa8c75bfba9845e9cb61f2e681"
21
22S = "${WORKDIR}/git"
23
24inherit update-alternatives
25
26ALTERNATIVE_PRIORITY = "100"
27ALTERNATIVE:${PN} = "acpixtract acpidump"
28
29EXTRA_OEMAKE = "CC='${CC}' \
30 OPT_CFLAGS=-Wall \
31 DESTDIR=${D} \
32 PREFIX=${prefix} \
33 INSTALLDIR=${bindir} \
34 INSTALLFLAGS= \
35 YACC=bison \
36 YFLAGS='-y --file-prefix-map=${WORKDIR}=${TARGET_DBGSRC_DIR}' \
37 "
38
39do_install() {
40 oe_runmake install
41}
42
43# iasl*.bb is a subset of this recipe, so RREPLACE it
44PROVIDES = "iasl"
45RPROVIDES:${PN} += "iasl"
46RREPLACES:${PN} += "iasl"
47RCONFLICTS:${PN} += "iasl"
48
49BBCLASSEXTEND = "native nativesdk"