diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2024-09-03 16:32:38 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-09-04 12:38:44 +0100 |
commit | f48465f04c8678b5431e98386b7de744d030da4e (patch) | |
tree | ef19ce3da0293d93c0b15a0196c66905a49ed5fc /meta/recipes-extended/acpica/acpica_20240827.bb | |
parent | ce383483f203b99c1ca4807947e07a5d96bcabce (diff) | |
download | poky-f48465f04c8678b5431e98386b7de744d030da4e.tar.gz |
acpica: upgrade 20240322 -> 20240827
Changelog:
==========
- Fix the PHAT table working: ensure that the PHAT firmware health record offset
works correctly, fix various sub-table offsets, prevent segmentation faults
when encountering invalid device paths.
- Fix the optional table 4-byte signature.
- Correct the dumping of SLIC and DBG2 tables.
- Add support for QWordPCC and DWordPCC
- Fix the integer to hex string conversions
- Detecting FACS in reduced HW mode and allowing setting waking vector thereby waking up from S3 state
- Fixing issues with crossing page boundaries when mapping operation regions
- Update the support for IORT, HMAT, MPAM, AEST, CEDT, SPCR etc. tables
- Fix multiple issues with table parsing, compilation and disassembly
- Allow for more flexibility in _DSM usage.
(From OE-Core rev: d1271e6435a399094152ceac540e160d87d7ae3b)
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20240827.bb')
-rw-r--r-- | meta/recipes-extended/acpica/acpica_20240827.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20240827.bb b/meta/recipes-extended/acpica/acpica_20240827.bb new file mode 100644 index 0000000000..7e8c68db90 --- /dev/null +++ b/meta/recipes-extended/acpica/acpica_20240827.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" | ||
2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ | ||
3 | OS-independent reference implementation of the Advanced Configuration and \ | ||
4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ | ||
5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ | ||
6 | subsystem, and a small set of tools to assist in developing and debugging \ | ||
7 | ACPI tables." | ||
8 | |||
9 | HOMEPAGE = "https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html" | ||
10 | SECTION = "console/tools" | ||
11 | |||
12 | LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only" | ||
13 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=05eb845b15a27440410f456adc2ed082" | ||
14 | |||
15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | ||
16 | |||
17 | DEPENDS = "m4-native flex-native bison-native" | ||
18 | |||
19 | SRC_URI = "git://github.com/acpica/acpica;protocol=https;branch=master" | ||
20 | SRCREV = "e80cbd7b52de20aa8c75bfba9845e9cb61f2e681" | ||
21 | |||
22 | S = "${WORKDIR}/git" | ||
23 | |||
24 | inherit update-alternatives | ||
25 | |||
26 | ALTERNATIVE_PRIORITY = "100" | ||
27 | ALTERNATIVE:${PN} = "acpixtract acpidump" | ||
28 | |||
29 | EXTRA_OEMAKE = "CC='${CC}' \ | ||
30 | OPT_CFLAGS=-Wall \ | ||
31 | DESTDIR=${D} \ | ||
32 | PREFIX=${prefix} \ | ||
33 | INSTALLDIR=${bindir} \ | ||
34 | INSTALLFLAGS= \ | ||
35 | YACC=bison \ | ||
36 | YFLAGS='-y --file-prefix-map=${WORKDIR}=${TARGET_DBGSRC_DIR}' \ | ||
37 | " | ||
38 | |||
39 | do_install() { | ||
40 | oe_runmake install | ||
41 | } | ||
42 | |||
43 | # iasl*.bb is a subset of this recipe, so RREPLACE it | ||
44 | PROVIDES = "iasl" | ||
45 | RPROVIDES:${PN} += "iasl" | ||
46 | RREPLACES:${PN} += "iasl" | ||
47 | RCONFLICTS:${PN} += "iasl" | ||
48 | |||
49 | BBCLASSEXTEND = "native nativesdk" | ||