summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_1.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index 464c5c5571..09715794b3 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -85,16 +85,16 @@ do_install_append() {
85 # Disable zypper channel support 85 # Disable zypper channel support
86 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/zyppchannelsync.py* 86 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/zyppchannelsync.py*
87 87
88 if [ -z "${@base_contains('PACKAGECONFIG', 'rpm', 'rpm', '', d)}" ]; then 88 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'rpm', 'rpm', '', d)}" ]; then
89 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/rpmdir.py* 89 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/rpmdir.py*
90 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/rpm 90 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/rpm
91 fi 91 fi
92 92
93 if [ -z "${@base_contains('PACKAGECONFIG', 'qt4', 'qt4', '', d)}" ]; then 93 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'qt4', 'qt4', '', d)}" ]; then
94 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt4 94 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt4
95 fi 95 fi
96 96
97 if [ -z "${@base_contains('PACKAGECONFIG', 'gtk+', 'gtk', '', d)}" ]; then 97 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'gtk', '', d)}" ]; then
98 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/gtk 98 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/gtk
99 fi 99 fi
100} 100}
@@ -115,9 +115,9 @@ do_install_append_class-nativesdk() {
115} 115}
116 116
117PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \ 117PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \
118 ${@base_contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \ 118 ${@bb.utils.contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \
119 ${@base_contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \ 119 ${@bb.utils.contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \
120 ${@base_contains('PACKAGECONFIG', 'gtk', '${PN}-interface-gtk', '', d)} \ 120 ${@bb.utils.contains('PACKAGECONFIG', 'gtk', '${PN}-interface-gtk', '', d)} \
121 ${PN}-interface-images ${PN}" 121 ${PN}-interface-images ${PN}"
122 122
123RDEPENDS_smartpm = "${PN}" 123RDEPENDS_smartpm = "${PN}"