summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-04-24 15:59:20 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-25 17:19:19 +0100
commit4c14b094985216c433d330fb3d9532d4b6c91fcf (patch)
tree6970f383436ca29450779bd98c378aae89f2e079 /meta/recipes-devtools/python/python-smartpm_1.4.1.bb
parent08a38a7865c41ec60f4b993b964f8d477ea0f680 (diff)
downloadpoky-4c14b094985216c433d330fb3d9532d4b6c91fcf.tar.gz
Globally replace 'base_contains' calls with 'bb.utils.contains'
The base_contains is kept as a compatibility method and we ought to not use it in OE-Core so we can remove it from base metadata in future. (From OE-Core rev: d83b16dbf0862be387f84228710cb165c6d2b03b) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_1.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index 464c5c5571..09715794b3 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -85,16 +85,16 @@ do_install_append() {
85 # Disable zypper channel support 85 # Disable zypper channel support
86 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/zyppchannelsync.py* 86 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/zyppchannelsync.py*
87 87
88 if [ -z "${@base_contains('PACKAGECONFIG', 'rpm', 'rpm', '', d)}" ]; then 88 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'rpm', 'rpm', '', d)}" ]; then
89 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/rpmdir.py* 89 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/rpmdir.py*
90 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/rpm 90 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/rpm
91 fi 91 fi
92 92
93 if [ -z "${@base_contains('PACKAGECONFIG', 'qt4', 'qt4', '', d)}" ]; then 93 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'qt4', 'qt4', '', d)}" ]; then
94 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt4 94 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt4
95 fi 95 fi
96 96
97 if [ -z "${@base_contains('PACKAGECONFIG', 'gtk+', 'gtk', '', d)}" ]; then 97 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'gtk', '', d)}" ]; then
98 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/gtk 98 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/gtk
99 fi 99 fi
100} 100}
@@ -115,9 +115,9 @@ do_install_append_class-nativesdk() {
115} 115}
116 116
117PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \ 117PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \
118 ${@base_contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \ 118 ${@bb.utils.contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \
119 ${@base_contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \ 119 ${@bb.utils.contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \
120 ${@base_contains('PACKAGECONFIG', 'gtk', '${PN}-interface-gtk', '', d)} \ 120 ${@bb.utils.contains('PACKAGECONFIG', 'gtk', '${PN}-interface-gtk', '', d)} \
121 ${PN}-interface-images ${PN}" 121 ${PN}-interface-images ${PN}"
122 122
123RDEPENDS_smartpm = "${PN}" 123RDEPENDS_smartpm = "${PN}"