summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pax-utils/pax-utils_1.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/pax-utils/pax-utils_1.1.4.bb')
-rw-r--r--meta/recipes-devtools/pax-utils/pax-utils_1.1.4.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pax-utils/pax-utils_1.1.4.bb b/meta/recipes-devtools/pax-utils/pax-utils_1.1.4.bb
new file mode 100644
index 0000000000..48b342e2e3
--- /dev/null
+++ b/meta/recipes-devtools/pax-utils/pax-utils_1.1.4.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Security-focused ELF files checking tool"
2DESCRIPTION = "This is a small set of various PaX aware and related \
3utilities for ELF binaries. It can check ELF binary files and running \
4processes for issues that might be relevant when using ELF binaries \
5along with PaX, such as non-PIC code or executable stack and heap."
6HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9
10SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz \
11 file://fix-configure-failure.patch \
12"
13
14SRC_URI[md5sum] = "1bfbb5237881f0c5e476b2f7ffcc00d5"
15SRC_URI[sha256sum] = "796860fbd48c5f811e699e8492dc1110459bad0a62efa8d346b74a4f6f556414"
16
17RDEPENDS_${PN} += "bash"
18
19do_configure_prepend() {
20 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog
21}
22
23do_install() {
24 oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
25}
26
27BBCLASSEXTEND = "native"
28
29inherit autotools pkgconfig
30
31PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
32"
33PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
34PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
35PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
36PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"