summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_git.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
new file mode 100644
index 0000000000..1e69067eeb
--- /dev/null
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 file://0001-Correctly-install-the-shared-library.patch \
10 "
11
12PV = "0.10.0+git${SRCPV}"
13SRCREV = "748891ff8ee524c2d37926c608cd2794f88013f3"
14
15S = "${WORKDIR}/git"
16
17DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
18DEPENDS_append_class-native = " file-replacement-native"
19
20inherit cmake pkgconfig bash-completion distutils-base
21
22EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}"
23
24BBCLASSEXTEND = "native"
25
26# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
27do_install_append_class-native() {
28 create_wrapper ${D}/${bindir}/createrepo_c \
29 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
30}
31