summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-12-30 18:34:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-14 14:42:16 +0000
commit4ab1f7606495d9e1c943bb0c7a63f46f6e829eab (patch)
tree14b64a1eef89256d22b6ffa99917772a6d3afdf5 /meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
parentc3df4543574888f6d52314a05266153e5a555892 (diff)
downloadpoky-4ab1f7606495d9e1c943bb0c7a63f46f6e829eab.tar.gz
createrepo-c: add a recipe
This is the current C reimplementation/replacement of the original createrepo. https://github.com/rpm-software-management/createrepo_c/wiki (From OE-Core rev: 30e0bec70f7793a5f923fc22c56b12bc1d06027d) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_git.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
new file mode 100644
index 0000000000..1e69067eeb
--- /dev/null
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 file://0001-Correctly-install-the-shared-library.patch \
10 "
11
12PV = "0.10.0+git${SRCPV}"
13SRCREV = "748891ff8ee524c2d37926c608cd2794f88013f3"
14
15S = "${WORKDIR}/git"
16
17DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
18DEPENDS_append_class-native = " file-replacement-native"
19
20inherit cmake pkgconfig bash-completion distutils-base
21
22EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}"
23
24BBCLASSEXTEND = "native"
25
26# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
27do_install_append_class-native() {
28 create_wrapper ${D}/${bindir}/createrepo_c \
29 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
30}
31