summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg_9a.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg_9a.bb')
-rw-r--r--meta/recipes-core/jpeg/jpeg_9a.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/jpeg/jpeg_9a.bb b/meta/recipes-core/jpeg/jpeg_9a.bb
new file mode 100644
index 0000000000..ea2e65d61a
--- /dev/null
+++ b/meta/recipes-core/jpeg/jpeg_9a.bb
@@ -0,0 +1,29 @@
1SUMMARY = "libjpeg is a library for handling the JPEG (JFIF) image format"
2DESCRIPTION = "libjpeg contains a library for handling the JPEG (JFIF) image format, as well as related programs for accessing the libjpeg functions."
3HOMEPAGE = "http://www.ijg.org/"
4
5LICENSE ="BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://README;md5=ea93a8a2fed10106b63bc21679edacb9"
7
8SECTION = "libs"
9
10SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
11 "
12
13SRC_URI[md5sum] = "3353992aecaee1805ef4109aadd433e7"
14SRC_URI[sha256sum] = "3a753ea48d917945dd54a2d97de388aa06ca2eb1066cbfdc6652036349fe05a7"
15
16inherit autotools
17
18PACKAGES =+ "jpeg-tools "
19DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs for access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files."
20FILES_jpeg-tools = "${bindir}/*"
21
22BBCLASSEXTEND = "native"
23
24pkg_postinst_${PN}_linuxstdbase () {
25 if [ ! -e $D${libdir}/libjpeg.so.62 ]; then
26 JPEG=`find $D${libdir} -type f -name libjpeg.so.\*.\*.\*`
27 ln -sf `basename $JPEG` $D${libdir}/libjpeg.so.62
28 fi
29}