summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/jpeg/jpeg_9a.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-06-04 13:21:50 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 12:36:00 +0100
commitb749251338972e019a108a988457c60f94032b4d (patch)
treebc623ea4e04dd0bad99e78eddec7e831a5eb0377 /meta/recipes-core/jpeg/jpeg_9a.bb
parent650fe92a0bab18fb8cf9b41b75b11cee264329ea (diff)
downloadpoky-b749251338972e019a108a988457c60f94032b4d.tar.gz
jpeg: update to version 9a
Previous webkit version was blocking this; latest webkit works fine. (From OE-Core rev: 5d9d179023857c53801e24b18f9b3051d9c84145) (From OE-Core rev: 5a4df6286399f59e081cbc8b7ffe25b713a54167) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/jpeg/jpeg_9a.bb')
-rw-r--r--meta/recipes-core/jpeg/jpeg_9a.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-core/jpeg/jpeg_9a.bb b/meta/recipes-core/jpeg/jpeg_9a.bb
new file mode 100644
index 0000000000..ea2e65d61a
--- /dev/null
+++ b/meta/recipes-core/jpeg/jpeg_9a.bb
@@ -0,0 +1,29 @@
1SUMMARY = "libjpeg is a library for handling the JPEG (JFIF) image format"
2DESCRIPTION = "libjpeg contains a library for handling the JPEG (JFIF) image format, as well as related programs for accessing the libjpeg functions."
3HOMEPAGE = "http://www.ijg.org/"
4
5LICENSE ="BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://README;md5=ea93a8a2fed10106b63bc21679edacb9"
7
8SECTION = "libs"
9
10SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
11 "
12
13SRC_URI[md5sum] = "3353992aecaee1805ef4109aadd433e7"
14SRC_URI[sha256sum] = "3a753ea48d917945dd54a2d97de388aa06ca2eb1066cbfdc6652036349fe05a7"
15
16inherit autotools
17
18PACKAGES =+ "jpeg-tools "
19DESCRIPTION_jpeg-tools = "The jpeg-tools package includes the client programs for access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files."
20FILES_jpeg-tools = "${bindir}/*"
21
22BBCLASSEXTEND = "native"
23
24pkg_postinst_${PN}_linuxstdbase () {
25 if [ ! -e $D${libdir}/libjpeg.so.62 ]; then
26 JPEG=`find $D${libdir} -type f -name libjpeg.so.\*.\*.\*`
27 ln -sf `basename $JPEG` $D${libdir}/libjpeg.so.62
28 fi
29}