summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb')
-rw-r--r--meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
new file mode 100644
index 0000000000..f528595c94
--- /dev/null
+++ b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Interface for user-level network packet capture"
2DESCRIPTION = "Libpcap provides a portable framework for low-level network \
3monitoring. Libpcap can provide network statistics collection, \
4security monitoring and network debugging."
5HOMEPAGE = "http://www.tcpdump.org/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=53067&atid=469577"
7SECTION = "libs/network"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453 \
10 file://pcap.h;beginline=1;endline=32;md5=39af3510e011f34b8872f120b1dc31d2"
11DEPENDS = "flex-native bison-native"
12
13SRC_URI = "https://www.tcpdump.org/release/${BP}.tar.gz"
14SRC_URI[sha256sum] = "ed285f4accaf05344f90975757b3dbfe772ba41d1c401c2648b7fa45b711bdd4"
15
16inherit autotools binconfig-disabled pkgconfig
17
18BINCONFIG = "${bindir}/pcap-config"
19
20# Explicitly disable dag support. We don't have recipe for it and if enabled here,
21# configure script poisons the include dirs with /usr/local/include even when the
22# support hasn't been detected.
23EXTRA_OECONF = " \
24 --with-pcap=linux \
25 --without-dag \
26 "
27EXTRA_AUTORECONF += "--exclude=aclocal"
28
29PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
30 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
31"
32PACKAGECONFIG[bluez5] = "--enable-bluetooth,--disable-bluetooth,bluez5"
33PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
34PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
35PACKAGECONFIG[libnl] = "--with-libnl,--without-libnl,libnl"
36
37do_configure_prepend () {
38 #remove hardcoded references to /usr/include
39 sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac
40}
41
42BBCLASSEXTEND = "native"