summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-06-14 22:51:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-17 13:42:31 +0100
commitfaefe113ac799afa22a7267cb84d2899f2844e20 (patch)
tree060f158209eca6b5ca0097771ae11220bb6e477e /meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
parent0f681265f53a713841725de704162886999704a8 (diff)
downloadpoky-faefe113ac799afa22a7267cb84d2899f2844e20.tar.gz
libpcap: upgrade 1.10.0 -> 1.10.1
Summary for 1.10.1 libpcap release Packet filtering: Fix "type XXX subtype YYY" giving a parse error Source code: Add PCAP_AVAILABLE_1_11. Building and testing: Rename struct bpf_aux_data to avoid NetBSD compile errors Squelch some compiler warnings Squelch some Bison warnings Fix cross-builds with older kernels lacking BPF_MOD and BPF_XOR Fix Bison detection for minor version 0. Fix parallel build with FreeBSD make. Get DLT_MATCHING_MAX right in gencode.c on NetBSD. Define timeradd() and timersub() if necessary. Fix Cygwin/MSYS target directories. Fix symlinking with DESTDIR. Fix generation of libpcap.pc with CMake when not building a shared library. Check for Arm64 as well as x86-64 when looking for packet.lib on Windows. Documentation: Refine Markdown in README.md. Improve the description of portrange in filters. README.linux.md isn't Markdown, rename it just README.linux. pcapng: Support reading version 1.2, which some writers produce, and which is the same as 1.0 (some new block types were added, but that's not sufficient reason to bump the minor version number, as code that understands those new block types can handle them in a 1.0 file) Linux: Drop support for text-mode USB captures, as we require a 2.6.27 or later kernel (credit to Chaoyuan Peng for noting the sscanf vulnerabilities in the text-mode code that got me to realize that we didn't need this code any more) Bluetooth: fix non-blocking mode. Don't assume that all compilers used to build for Linux support the __atomic builtins Windows: ... rpcap: Clean up error checking and error messages for server address lookup. (From OE-Core rev: bcd20c78be3828903c18fcb40853e7146cc85fdb) Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb')
-rw-r--r--meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
new file mode 100644
index 0000000000..f528595c94
--- /dev/null
+++ b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Interface for user-level network packet capture"
2DESCRIPTION = "Libpcap provides a portable framework for low-level network \
3monitoring. Libpcap can provide network statistics collection, \
4security monitoring and network debugging."
5HOMEPAGE = "http://www.tcpdump.org/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=53067&atid=469577"
7SECTION = "libs/network"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453 \
10 file://pcap.h;beginline=1;endline=32;md5=39af3510e011f34b8872f120b1dc31d2"
11DEPENDS = "flex-native bison-native"
12
13SRC_URI = "https://www.tcpdump.org/release/${BP}.tar.gz"
14SRC_URI[sha256sum] = "ed285f4accaf05344f90975757b3dbfe772ba41d1c401c2648b7fa45b711bdd4"
15
16inherit autotools binconfig-disabled pkgconfig
17
18BINCONFIG = "${bindir}/pcap-config"
19
20# Explicitly disable dag support. We don't have recipe for it and if enabled here,
21# configure script poisons the include dirs with /usr/local/include even when the
22# support hasn't been detected.
23EXTRA_OECONF = " \
24 --with-pcap=linux \
25 --without-dag \
26 "
27EXTRA_AUTORECONF += "--exclude=aclocal"
28
29PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
30 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
31"
32PACKAGECONFIG[bluez5] = "--enable-bluetooth,--disable-bluetooth,bluez5"
33PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
34PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
35PACKAGECONFIG[libnl] = "--with-libnl,--without-libnl,libnl"
36
37do_configure_prepend () {
38 #remove hardcoded references to /usr/include
39 sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac
40}
41
42BBCLASSEXTEND = "native"