diff options
Diffstat (limited to 'meta/recipes-bsp/grub/grub_git.bb')
-rw-r--r-- | meta/recipes-bsp/grub/grub_git.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb new file mode 100644 index 0000000000..d4e09faa40 --- /dev/null +++ b/meta/recipes-bsp/grub/grub_git.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | require grub2.inc | ||
2 | |||
3 | RDEPENDS_${PN}-common += "${PN}-editenv" | ||
4 | RDEPENDS_${PN} += "${PN}-common" | ||
5 | RDEPENDS_${PN}_class-native = "" | ||
6 | |||
7 | RPROVIDES_${PN}-editenv += "${PN}-efi-editenv" | ||
8 | |||
9 | PROVIDES_append_class-native = " grub-efi-native" | ||
10 | |||
11 | PACKAGES =+ "${PN}-editenv ${PN}-common" | ||
12 | FILES_${PN}-editenv = "${bindir}/grub-editenv" | ||
13 | FILES_${PN}-common = " \ | ||
14 | ${bindir} \ | ||
15 | ${sysconfdir} \ | ||
16 | ${sbindir} \ | ||
17 | ${datadir}/grub \ | ||
18 | " | ||
19 | ALLOW_EMPTY_${PN} = "1" | ||
20 | |||
21 | do_install_append () { | ||
22 | # Avoid conflicts with the EFI package for systems such as arm64 where we | ||
23 | # need to build grub and grub-efi but only EFI is supported by removing EFI | ||
24 | # from this package. | ||
25 | rm -rf ${D}${libdir}/grub/*-efi/ | ||
26 | rmdir --ignore-fail-on-non-empty ${D}${libdir}/grub ${D}${libdir} | ||
27 | |||
28 | install -d ${D}${sysconfdir}/grub.d | ||
29 | # Remove build host references... | ||
30 | find "${D}" -name modinfo.sh -type f -exec \ | ||
31 | sed -i \ | ||
32 | -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ | ||
33 | -e 's|${DEBUG_PREFIX_MAP}||g' \ | ||
34 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ | ||
35 | {} + | ||
36 | } | ||
37 | |||
38 | INSANE_SKIP_${PN} = "arch" | ||
39 | INSANE_SKIP_${PN}-dbg = "arch" | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | ||