summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_git.bb
diff options
context:
space:
mode:
authorNaveen Saini <naveen.kumar.saini@intel.com>2021-03-19 15:14:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-20 18:54:56 +0000
commitda9b0583de455b48b91d2afe73200dcc0d778da3 (patch)
tree27bc885f4749712e2514924f195bc86cee41096e /meta/recipes-bsp/grub/grub_git.bb
parent9825a860eef8b6003c917969805cc2975ffeb3dc (diff)
downloadpoky-da9b0583de455b48b91d2afe73200dcc0d778da3.tar.gz
grub: upgrade 2.04 -> 2.06~rc1
2.06 RC1 release have a number of CVEs fixed: CVE-2020-15705 CVE-2021-3418 CVE-2020-27749 CVE-2021-20233 CVE-2021-20225 CVE-2020-25647 CVE-2020-25632 CVE-2020-27779 CVE-2020-14372 CVE-2020-15707 CVE-2020-15706 CVE-2020-14309 CVE-2020-14310 CVE-2020-14311 CVE-2020-14308 CVE-2020-10713 CVE-2014-4607 Dropped backported patches. (From OE-Core rev: 36a59d63619c2225fe48aa1d8fb1cdabedfffc03) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-bsp/grub/grub_git.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
new file mode 100644
index 0000000000..d4e09faa40
--- /dev/null
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -0,0 +1,41 @@
1require grub2.inc
2
3RDEPENDS_${PN}-common += "${PN}-editenv"
4RDEPENDS_${PN} += "${PN}-common"
5RDEPENDS_${PN}_class-native = ""
6
7RPROVIDES_${PN}-editenv += "${PN}-efi-editenv"
8
9PROVIDES_append_class-native = " grub-efi-native"
10
11PACKAGES =+ "${PN}-editenv ${PN}-common"
12FILES_${PN}-editenv = "${bindir}/grub-editenv"
13FILES_${PN}-common = " \
14 ${bindir} \
15 ${sysconfdir} \
16 ${sbindir} \
17 ${datadir}/grub \
18"
19ALLOW_EMPTY_${PN} = "1"
20
21do_install_append () {
22 # Avoid conflicts with the EFI package for systems such as arm64 where we
23 # need to build grub and grub-efi but only EFI is supported by removing EFI
24 # from this package.
25 rm -rf ${D}${libdir}/grub/*-efi/
26 rmdir --ignore-fail-on-non-empty ${D}${libdir}/grub ${D}${libdir}
27
28 install -d ${D}${sysconfdir}/grub.d
29 # Remove build host references...
30 find "${D}" -name modinfo.sh -type f -exec \
31 sed -i \
32 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
33 -e 's|${DEBUG_PREFIX_MAP}||g' \
34 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
35 {} +
36}
37
38INSANE_SKIP_${PN} = "arch"
39INSANE_SKIP_${PN}-dbg = "arch"
40
41BBCLASSEXTEND = "native nativesdk"