summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-skeleton
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/recipes-skeleton')
-rw-r--r--meta-skeleton/recipes-skeleton/hello-autotools/hello_2.10.bb9
-rw-r--r--meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c8
-rw-r--r--meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb17
-rw-r--r--meta-skeleton/recipes-skeleton/libxpm/libxpm_3.5.6.bb13
-rw-r--r--meta-skeleton/recipes-skeleton/service/service_0.1.bb9
-rw-r--r--meta-skeleton/recipes-skeleton/useradd/useradd-example.bb17
6 files changed, 61 insertions, 12 deletions
diff --git a/meta-skeleton/recipes-skeleton/hello-autotools/hello_2.10.bb b/meta-skeleton/recipes-skeleton/hello-autotools/hello_2.10.bb
new file mode 100644
index 0000000000..a64088fbaa
--- /dev/null
+++ b/meta-skeleton/recipes-skeleton/hello-autotools/hello_2.10.bb
@@ -0,0 +1,9 @@
1DESCRIPTION = "GNU Helloworld application"
2SECTION = "examples"
3LICENSE = "GPL-3.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6SRC_URI = "${GNU_MIRROR}/hello/hello-${PV}.tar.gz"
7SRC_URI[sha256sum] = "31e066137a962676e89f69d1b65382de95a7ef7d914b8cb956f41ea72e0f516b"
8
9inherit autotools-brokensep gettext
diff --git a/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c b/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c
new file mode 100644
index 0000000000..fc7169b7b8
--- /dev/null
+++ b/meta-skeleton/recipes-skeleton/hello-single/files/helloworld.c
@@ -0,0 +1,8 @@
1#include <stdio.h>
2
3int main(void)
4{
5 printf("Hello world!\n");
6
7 return 0;
8}
diff --git a/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb b/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
new file mode 100644
index 0000000000..90d3aefd86
--- /dev/null
+++ b/meta-skeleton/recipes-skeleton/hello-single/hello_1.0.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "Simple helloworld application"
2SECTION = "examples"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6SRC_URI = "file://helloworld.c"
7
8S = "${WORKDIR}"
9
10do_compile() {
11 ${CC} ${LDFLAGS} helloworld.c -o helloworld
12}
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 helloworld ${D}${bindir}
17}
diff --git a/meta-skeleton/recipes-skeleton/libxpm/libxpm_3.5.6.bb b/meta-skeleton/recipes-skeleton/libxpm/libxpm_3.5.6.bb
new file mode 100644
index 0000000000..1fcbbdd65e
--- /dev/null
+++ b/meta-skeleton/recipes-skeleton/libxpm/libxpm_3.5.6.bb
@@ -0,0 +1,13 @@
1require recipes-graphics/xorg-lib/xorg-lib-common.inc
2
3DESCRIPTION = "X11 Pixmap library"
4LICENSE = "X-BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=3e07763d16963c3af12db271a31abaa5"
6DEPENDS += "libxext"
7PE = "1"
8
9XORG_PN = "libXpm"
10
11PACKAGES =+ "sxpm cxpm"
12FILES:cxpm = "${bindir}/cxpm"
13FILES:sxpm = "${bindir}/sxpm"
diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
index 6416618dcb..912f6b0f61 100644
--- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
@@ -1,6 +1,7 @@
1SUMMARY = "The canonical example of init scripts" 1SUMMARY = "The canonical example of init scripts"
2SECTION = "base" 2SECTION = "base"
3LICENSE = "GPLv2" 3DESCRIPTION = "This recipe is a canonical example of init scripts"
4LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4" 5LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
5 6
6SRC_URI = "file://skeleton \ 7SRC_URI = "file://skeleton \
@@ -8,6 +9,8 @@ SRC_URI = "file://skeleton \
8 file://COPYRIGHT \ 9 file://COPYRIGHT \
9 " 10 "
10 11
12S = "${WORKDIR}"
13
11do_compile () { 14do_compile () {
12 ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test 15 ${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
13} 16}
@@ -26,6 +29,6 @@ do_install () {
26 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/ 29 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
27} 30}
28 31
29RDEPENDS_${PN} = "initscripts" 32RDEPENDS:${PN} = "initscripts"
30 33
31CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton" 34CONFFILES:${PN} += "${sysconfdir}/init.d/skeleton"
diff --git a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
index 7c5b9d0503..8437a5a774 100644
--- a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
+++ b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
@@ -1,7 +1,6 @@
1SUMMARY = "Example recipe for using inherit useradd" 1SUMMARY = "Example recipe for using inherit useradd"
2DESCRIPTION = "This recipe serves as an example for using features from useradd.bbclass" 2DESCRIPTION = "This recipe serves as an example for using features from useradd.bbclass"
3SECTION = "examples" 3SECTION = "examples"
4PR = "r1"
5LICENSE = "MIT" 4LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" 5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7 6
@@ -30,19 +29,19 @@ USERADD_PACKAGES = "${PN} ${PN}-user3"
30# useradd command. Multiple users can be created by separating 29# useradd command. Multiple users can be created by separating
31# the commands with a semicolon. Here we'll create two users, 30# the commands with a semicolon. Here we'll create two users,
32# user1 and user2: 31# user1 and user2:
33USERADD_PARAM_${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2" 32USERADD_PARAM:${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2"
34 33
35# user3 will be managed in the useradd-example-user3 pacakge: 34# user3 will be managed in the useradd-example-user3 package:
36# As an example, we use the -P option to set clear text password for user3 35# As an example, we use the -p option to set password ('user3') for user3
37USERADD_PARAM_${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3" 36USERADD_PARAM:${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -p '\$6\$XAWr.8nc\$bUE4pYYaVb8n6BbnBitU0zeJMtfhTpFpiOBLL9zRl4e4YQo88UU4r/1kjRzmTimCy.BvDh4xoFwVqcO.pihLa1' user3"
38 37
39# GROUPADD_PARAM works the same way, which you set to the options 38# GROUPADD_PARAM works the same way, which you set to the options
40# you'd normally pass to the groupadd command. This will create 39# you'd normally pass to the groupadd command. This will create
41# groups group1 and group2: 40# groups group1 and group2:
42GROUPADD_PARAM_${PN} = "-g 880 group1; -g 890 group2" 41GROUPADD_PARAM:${PN} = "-g 880 group1; -g 890 group2"
43 42
44# Likewise, we'll manage group3 in the useradd-example-user3 package: 43# Likewise, we'll manage group3 in the useradd-example-user3 package:
45GROUPADD_PARAM_${PN}-user3 = "-g 900 group3" 44GROUPADD_PARAM:${PN}-user3 = "-g 900 group3"
46 45
47do_install () { 46do_install () {
48 install -d -m 755 ${D}${datadir}/user1 47 install -d -m 755 ${D}${datadir}/user1
@@ -69,8 +68,8 @@ do_install () {
69 chgrp -R group3 ${D}${datadir}/user3 68 chgrp -R group3 ${D}${datadir}/user3
70} 69}
71 70
72FILES_${PN} = "${datadir}/user1/* ${datadir}/user2/*" 71FILES:${PN} = "${datadir}/user1/* ${datadir}/user2/*"
73FILES_${PN}-user3 = "${datadir}/user3/*" 72FILES:${PN}-user3 = "${datadir}/user3/*"
74 73
75# Prevents do_package failures with: 74# Prevents do_package failures with:
76# debugsources.list: No such file or directory: 75# debugsources.list: No such file or directory: