summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
diff options
context:
space:
mode:
authorNg, Wei Tee <wei.tee.ng@intel.com>2017-07-23 16:51:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-27 22:36:53 +0100
commit8b960914ac6193c2146eb1bb39fc9ec5c0008404 (patch)
treea69dccd8278e5d3b780042ac5bf2fedd77629c4c /meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
parent716d5d9e65ad05712e127e575bd5e9c68178d33e (diff)
downloadpoky-8b960914ac6193c2146eb1bb39fc9ec5c0008404.tar.gz
initramfs-framework: include install-efi module in recipe for installation
Utilized the existing init-install-efi.sh script and renamed it to install-efi.sh to manage the installation process of images in initramfs-framework model. This script will be executed when "install" option is being chosen in the grub menu and install the image on the target platform. A new install-efi module is being added in the recipe to handle the installation process using initramfs-framework. [YOCTO #10989] (From OE-Core rev: 41b34441c22143cbabace3d794ead05801afb7a0) Signed-off-by: Ng, Wei Tee <wei.tee.ng@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb')
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb19
1 files changed, 16 insertions, 3 deletions
diff --git a/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
index 211e89d5d3..9d69a696f1 100644
--- a/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
+++ b/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
@@ -5,7 +5,11 @@ RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_base-utils}"
5 5
6PR = "r2" 6PR = "r2"
7 7
8inherit allarch 8# While the packages maybe an allarch due to it being a
9# simple script, reality is that it is Host specific based
10# on the COMPATIBLE_HOST below, which needs to take precedence
11#inherit allarch
12INHIBIT_DEFAULT_DEPS = "1"
9 13
10SRC_URI = "file://init \ 14SRC_URI = "file://init \
11 file://rootfs \ 15 file://rootfs \
@@ -14,7 +18,8 @@ SRC_URI = "file://init \
14 file://udev \ 18 file://udev \
15 file://e2fs \ 19 file://e2fs \
16 file://debug \ 20 file://debug \
17 file://setup-live" 21 file://setup-live \
22 file://install-efi.sh"
18 23
19S = "${WORKDIR}" 24S = "${WORKDIR}"
20 25
@@ -41,6 +46,9 @@ do_install() {
41 # debug 46 # debug
42 install -m 0755 ${WORKDIR}/debug ${D}/init.d/00-debug 47 install -m 0755 ${WORKDIR}/debug ${D}/init.d/00-debug
43 48
49 # install-efi
50 install -m 0755 ${WORKDIR}/install-efi.sh ${D}/init.d/install-efi.sh
51
44 # Create device nodes expected by some kernels in initramfs 52 # Create device nodes expected by some kernels in initramfs
45 # before even executing /init. 53 # before even executing /init.
46 install -d ${D}/dev 54 install -d ${D}/dev
@@ -53,7 +61,8 @@ PACKAGES = "${PN}-base \
53 initramfs-module-e2fs \ 61 initramfs-module-e2fs \
54 initramfs-module-rootfs \ 62 initramfs-module-rootfs \
55 initramfs-module-debug \ 63 initramfs-module-debug \
56 initramfs-module-setup-live" 64 initramfs-module-setup-live \
65 initramfs-module-install-efi"
57 66
58FILES_${PN}-base = "/init /init.d/99-finish /dev" 67FILES_${PN}-base = "/init /init.d/99-finish /dev"
59 68
@@ -88,3 +97,7 @@ FILES_initramfs-module-rootfs = "/init.d/90-rootfs"
88SUMMARY_initramfs-module-debug = "initramfs dynamic debug support" 97SUMMARY_initramfs-module-debug = "initramfs dynamic debug support"
89RDEPENDS_initramfs-module-debug = "${PN}-base" 98RDEPENDS_initramfs-module-debug = "${PN}-base"
90FILES_initramfs-module-debug = "/init.d/00-debug" 99FILES_initramfs-module-debug = "/init.d/00-debug"
100
101SUMMARY_initramfs-module-install-efi = "initramfs support for installation option"
102RDEPENDS_initramfs-module-install-efi = "${PN}-base parted e2fsprogs-mke2fs dosfstools util-linux-blkid"
103FILES_initramfs-module-install-efi = "/init.d/install-efi.sh"