summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
diff options
context:
space:
mode:
authorNg, Wei Tee <wei.tee.ng@intel.com>2017-07-23 16:51:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-27 22:36:53 +0100
commit716d5d9e65ad05712e127e575bd5e9c68178d33e (patch)
tree76ee7308ef33ddd7f839a0ffe5b13a9fb4f2a276 /meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
parent05e4f13971883441503823e430f44c8136be660f (diff)
downloadpoky-716d5d9e65ad05712e127e575bd5e9c68178d33e.tar.gz
initramfs-framework: module to support boot live image
setup-live module is a new module being introduced to integrate the functionality of init-live.sh into new scriptlet named setup-live in order to support the live boot image. The udev-extraconf rdepends is being added to perform automounting. It gets to run before the rootfs and finish module. The setup-live scriplet include the changes for: - Create a conditional loop for the bootparam_root variable. If it is not set, then it will boot from ROOT_IMAGE. Else, it will boot normally which is not from removable media. - Gives a standard path to the original boot disk mount which can be used to. While /media/sda is a good guess, it isn't always right, nor is it a good assumption that only one boot disk is in the system. - The current rootfs module has no support for rootfs images, currently it only support for rootfs partitions for wic image. Therefore, there is a need to assign the rootfs image for live image. [YOCTO #11701] (From OE-Core rev: 4d3300e85a8e65207a415b9cf84c9fa1f71b0406) Signed-off-by: Ng, Wei Tee <wei.tee.ng@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb')
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
index 67a1b04d28..211e89d5d3 100644
--- a/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
+++ b/meta/recipes-core/initrdscripts/initramfs-framework_1.0.bb
@@ -13,7 +13,8 @@ SRC_URI = "file://init \
13 file://mdev \ 13 file://mdev \
14 file://udev \ 14 file://udev \
15 file://e2fs \ 15 file://e2fs \
16 file://debug" 16 file://debug \
17 file://setup-live"
17 18
18S = "${WORKDIR}" 19S = "${WORKDIR}"
19 20
@@ -25,6 +26,9 @@ do_install() {
25 install -m 0755 ${WORKDIR}/rootfs ${D}/init.d/90-rootfs 26 install -m 0755 ${WORKDIR}/rootfs ${D}/init.d/90-rootfs
26 install -m 0755 ${WORKDIR}/finish ${D}/init.d/99-finish 27 install -m 0755 ${WORKDIR}/finish ${D}/init.d/99-finish
27 28
29 # setup-live
30 install -m 0755 ${WORKDIR}/setup-live ${D}/init.d/80-setup-live
31
28 # mdev 32 # mdev
29 install -m 0755 ${WORKDIR}/mdev ${D}/init.d/01-mdev 33 install -m 0755 ${WORKDIR}/mdev ${D}/init.d/01-mdev
30 34
@@ -48,7 +52,8 @@ PACKAGES = "${PN}-base \
48 initramfs-module-udev \ 52 initramfs-module-udev \
49 initramfs-module-e2fs \ 53 initramfs-module-e2fs \
50 initramfs-module-rootfs \ 54 initramfs-module-rootfs \
51 initramfs-module-debug" 55 initramfs-module-debug \
56 initramfs-module-setup-live"
52 57
53FILES_${PN}-base = "/init /init.d/99-finish /dev" 58FILES_${PN}-base = "/init /init.d/99-finish /dev"
54 59
@@ -68,6 +73,10 @@ SUMMARY_initramfs-module-udev = "initramfs support for udev"
68RDEPENDS_initramfs-module-udev = "${PN}-base udev" 73RDEPENDS_initramfs-module-udev = "${PN}-base udev"
69FILES_initramfs-module-udev = "/init.d/01-udev" 74FILES_initramfs-module-udev = "/init.d/01-udev"
70 75
76SUMMARY_initramfs-module-setup-live = "initramfs support for setup live"
77RDEPENDS_initramfs-module-setup-live = "${PN}-base udev-extraconf"
78FILES_initramfs-module-setup-live = "/init.d/80-setup-live"
79
71SUMMARY_initramfs-module-e2fs = "initramfs support for ext4/ext3/ext2 filesystems" 80SUMMARY_initramfs-module-e2fs = "initramfs support for ext4/ext3/ext2 filesystems"
72RDEPENDS_initramfs-module-e2fs = "${PN}-base" 81RDEPENDS_initramfs-module-e2fs = "${PN}-base"
73FILES_initramfs-module-e2fs = "/init.d/10-e2fs" 82FILES_initramfs-module-e2fs = "/init.d/10-e2fs"