summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxml/libxml2_2.6.26.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-05-04 15:23:34 +0000
committerRoss Burton <ross@openedhand.com>2007-05-04 15:23:34 +0000
commit8b9d8e6399e74c3a38f2de86dcf20f68cc4a84d2 (patch)
tree882ddcf62931e20307004ffae6d1b2f4b102ec29 /meta/packages/libxml/libxml2_2.6.26.bb
parentb180d8467510993d7045729dba477920a844bd9a (diff)
downloadpoky-8b9d8e6399e74c3a38f2de86dcf20f68cc4a84d2.tar.gz
Upgrade libxml2 version
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1598 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libxml/libxml2_2.6.26.bb')
-rw-r--r--meta/packages/libxml/libxml2_2.6.26.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/packages/libxml/libxml2_2.6.26.bb b/meta/packages/libxml/libxml2_2.6.26.bb
new file mode 100644
index 0000000000..e330050b81
--- /dev/null
+++ b/meta/packages/libxml/libxml2_2.6.26.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "GNOME XML Parser library"
2SECTION = "libs"
3PRIORITY = "optional"
4LICENSE = "MIT"
5PR = "r4"
6
7SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
8 file://no-testapi.patch;patch=1"
9
10inherit autotools pkgconfig binconfig
11
12EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n --without-schemas --without-schematron --with-reader"
13
14export LDFLAGS += "-ldl"
15
16do_stage() {
17 autotools_stage_all
18 install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
19 #this is need it by php during its install
20 install -m 0755 xml2-config ${STAGING_BINDIR}
21}
22
23python populate_packages_prepend () {
24 # autonamer would call this libxml2-2, but we don't want that
25 if bb.data.getVar('DEBIAN_NAMES', d, 1):
26 bb.data.setVar('PKG_libxml2', 'libxml2', d)
27}
28
29PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
30
31FILES_${PN}-dev += "${bindir}/*-config"
32FILES_${PN}-utils += "${bindir}/*"