summaryrefslogtreecommitdiffstats
path: root/meta/packages/libxml
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-05-04 15:23:34 +0000
committerRoss Burton <ross@openedhand.com>2007-05-04 15:23:34 +0000
commit8b9d8e6399e74c3a38f2de86dcf20f68cc4a84d2 (patch)
tree882ddcf62931e20307004ffae6d1b2f4b102ec29 /meta/packages/libxml
parentb180d8467510993d7045729dba477920a844bd9a (diff)
downloadpoky-8b9d8e6399e74c3a38f2de86dcf20f68cc4a84d2.tar.gz
Upgrade libxml2 version
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1598 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/libxml')
-rw-r--r--meta/packages/libxml/libxml2_2.6.22.bb39
-rw-r--r--meta/packages/libxml/libxml2_2.6.26.bb32
2 files changed, 32 insertions, 39 deletions
diff --git a/meta/packages/libxml/libxml2_2.6.22.bb b/meta/packages/libxml/libxml2_2.6.22.bb
deleted file mode 100644
index 82494fe75e..0000000000
--- a/meta/packages/libxml/libxml2_2.6.22.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1PR = "r2"
2DESCRIPTION = "GNOME XML library"
3SECTION = "libs"
4PRIORITY = "optional"
5LICENSE = "MIT"
6PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
7
8FILES_${PN}-dev += "${bindir}/xml-config"
9FILES_${PN}-utils += "${bindir}/*"
10
11SRC_URI = "http://xmlsoft.org/sources/libxml2/libxml2-${PV}.tar.gz \
12 file://no-testapi.patch;patch=1"
13inherit autotools pkgconfig
14
15EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --without-c14n --without-schemas --without-schematron"
16
17headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
18
19do_stage () {
20 oe_libinstall -so libxml2 ${STAGING_LIBDIR}
21
22 mkdir -p ${STAGING_INCDIR}/libxml2/libxml
23 for i in ${headers}; do
24 install -m 0644 include/libxml/$i ${STAGING_INCDIR}/libxml2/libxml/$i
25 done
26
27 cat xml2-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
28 -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
29 -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
30 -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR_CROSS}/xml2-config
31 chmod a+rx ${STAGING_BINDIR_CROSS}/xml2-config
32 install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
33}
34
35python populate_packages_prepend () {
36 # autonamer would call this libxml2-2, but we don't want that
37 if bb.data.getVar('DEBIAN_NAMES', d, 1):
38 bb.data.setVar('PKG_libxml2', 'libxml2', d)
39}
diff --git a/meta/packages/libxml/libxml2_2.6.26.bb b/meta/packages/libxml/libxml2_2.6.26.bb
new file mode 100644
index 0000000000..e330050b81
--- /dev/null
+++ b/meta/packages/libxml/libxml2_2.6.26.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "GNOME XML Parser library"
2SECTION = "libs"
3PRIORITY = "optional"
4LICENSE = "MIT"
5PR = "r4"
6
7SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
8 file://no-testapi.patch;patch=1"
9
10inherit autotools pkgconfig binconfig
11
12EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n --without-schemas --without-schematron --with-reader"
13
14export LDFLAGS += "-ldl"
15
16do_stage() {
17 autotools_stage_all
18 install -m 0644 libxml.m4 ${STAGING_DATADIR}/aclocal/
19 #this is need it by php during its install
20 install -m 0755 xml2-config ${STAGING_BINDIR}
21}
22
23python populate_packages_prepend () {
24 # autonamer would call this libxml2-2, but we don't want that
25 if bb.data.getVar('DEBIAN_NAMES', d, 1):
26 bb.data.setVar('PKG_libxml2', 'libxml2', d)
27}
28
29PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
30
31FILES_${PN}-dev += "${bindir}/*-config"
32FILES_${PN}-utils += "${bindir}/*"