summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/cargo.bbclass
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2023-12-08 12:00:26 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-09 19:17:11 +0000
commit43df94f7af8422ebd1f2884992349ff1baae232b (patch)
tree1f227af30b9660ecfa524e9f6b2c869b0c662045 /meta/classes-recipe/cargo.bbclass
parentdb73316fea6b4791cdd7064c7b0ccc5b777212ca (diff)
downloadpoky-43df94f7af8422ebd1f2884992349ff1baae232b.tar.gz
cargo: Move CARGO_MANIFEST_PATH/CARGO_SRC_DIR to cargo_common
cargo_common_do_configure uses CARGO_MANIFEST_PATH (which depends on CARGO_SRC_DIR), but their definition was in cargo.bbclass. (From OE-Core rev: 740374a13ad5359767b421666decf50c158ea0df) Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes-recipe/cargo.bbclass')
-rw-r--r--meta/classes-recipe/cargo.bbclass7
1 files changed, 0 insertions, 7 deletions
diff --git a/meta/classes-recipe/cargo.bbclass b/meta/classes-recipe/cargo.bbclass
index 96a74e2ef1..0829a58dd9 100644
--- a/meta/classes-recipe/cargo.bbclass
+++ b/meta/classes-recipe/cargo.bbclass
@@ -30,13 +30,6 @@ B = "${WORKDIR}/build"
30# where the issue occured 30# where the issue occured
31export RUST_BACKTRACE = "1" 31export RUST_BACKTRACE = "1"
32 32
33# The directory of the Cargo.toml relative to the root directory, per default
34# assume there's a Cargo.toml directly in the root directory
35CARGO_SRC_DIR ??= ""
36
37# The actual path to the Cargo.toml
38CARGO_MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml"
39
40RUSTFLAGS ??= "" 33RUSTFLAGS ??= ""
41BUILD_MODE = "${@['--release', ''][d.getVar('DEBUG_BUILD') == '1']}" 34BUILD_MODE = "${@['--release', ''][d.getVar('DEBUG_BUILD') == '1']}"
42# --frozen flag will prevent network access (which is required since only 35# --frozen flag will prevent network access (which is required since only