summaryrefslogtreecommitdiffstats
path: root/meta/classes-recipe/cargo.bbclass
diff options
context:
space:
mode:
Diffstat (limited to 'meta/classes-recipe/cargo.bbclass')
-rw-r--r--meta/classes-recipe/cargo.bbclass7
1 files changed, 0 insertions, 7 deletions
diff --git a/meta/classes-recipe/cargo.bbclass b/meta/classes-recipe/cargo.bbclass
index 96a74e2ef1..0829a58dd9 100644
--- a/meta/classes-recipe/cargo.bbclass
+++ b/meta/classes-recipe/cargo.bbclass
@@ -30,13 +30,6 @@ B = "${WORKDIR}/build"
30# where the issue occured 30# where the issue occured
31export RUST_BACKTRACE = "1" 31export RUST_BACKTRACE = "1"
32 32
33# The directory of the Cargo.toml relative to the root directory, per default
34# assume there's a Cargo.toml directly in the root directory
35CARGO_SRC_DIR ??= ""
36
37# The actual path to the Cargo.toml
38CARGO_MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml"
39
40RUSTFLAGS ??= "" 33RUSTFLAGS ??= ""
41BUILD_MODE = "${@['--release', ''][d.getVar('DEBUG_BUILD') == '1']}" 34BUILD_MODE = "${@['--release', ''][d.getVar('DEBUG_BUILD') == '1']}"
42# --frozen flag will prevent network access (which is required since only 35# --frozen flag will prevent network access (which is required since only