summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-skeleton
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 15:44:10 +0100
commitbb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch)
tree76e376b01253c3aace1a98a5021bcaad3c92e861 /meta-skeleton/recipes-skeleton
parentfcc456ee4b8f619134abb4649db53c638074082c (diff)
downloadpoky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". (From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton/recipes-skeleton')
-rw-r--r--meta-skeleton/recipes-skeleton/service/service_0.1.bb4
-rw-r--r--meta-skeleton/recipes-skeleton/useradd/useradd-example.bb12
2 files changed, 8 insertions, 8 deletions
diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
index 669d173ad1..2c048aa050 100644
--- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
@@ -27,6 +27,6 @@ do_install () {
27 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/ 27 install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
28} 28}
29 29
30RDEPENDS_${PN} = "initscripts" 30RDEPENDS:${PN} = "initscripts"
31 31
32CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton" 32CONFFILES:${PN} += "${sysconfdir}/init.d/skeleton"
diff --git a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
index 7c5b9d0503..3f4c42d714 100644
--- a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
+++ b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb
@@ -30,19 +30,19 @@ USERADD_PACKAGES = "${PN} ${PN}-user3"
30# useradd command. Multiple users can be created by separating 30# useradd command. Multiple users can be created by separating
31# the commands with a semicolon. Here we'll create two users, 31# the commands with a semicolon. Here we'll create two users,
32# user1 and user2: 32# user1 and user2:
33USERADD_PARAM_${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2" 33USERADD_PARAM:${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2"
34 34
35# user3 will be managed in the useradd-example-user3 pacakge: 35# user3 will be managed in the useradd-example-user3 pacakge:
36# As an example, we use the -P option to set clear text password for user3 36# As an example, we use the -P option to set clear text password for user3
37USERADD_PARAM_${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3" 37USERADD_PARAM:${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3"
38 38
39# GROUPADD_PARAM works the same way, which you set to the options 39# GROUPADD_PARAM works the same way, which you set to the options
40# you'd normally pass to the groupadd command. This will create 40# you'd normally pass to the groupadd command. This will create
41# groups group1 and group2: 41# groups group1 and group2:
42GROUPADD_PARAM_${PN} = "-g 880 group1; -g 890 group2" 42GROUPADD_PARAM:${PN} = "-g 880 group1; -g 890 group2"
43 43
44# Likewise, we'll manage group3 in the useradd-example-user3 package: 44# Likewise, we'll manage group3 in the useradd-example-user3 package:
45GROUPADD_PARAM_${PN}-user3 = "-g 900 group3" 45GROUPADD_PARAM:${PN}-user3 = "-g 900 group3"
46 46
47do_install () { 47do_install () {
48 install -d -m 755 ${D}${datadir}/user1 48 install -d -m 755 ${D}${datadir}/user1
@@ -69,8 +69,8 @@ do_install () {
69 chgrp -R group3 ${D}${datadir}/user3 69 chgrp -R group3 ${D}${datadir}/user3
70} 70}
71 71
72FILES_${PN} = "${datadir}/user1/* ${datadir}/user2/*" 72FILES:${PN} = "${datadir}/user1/* ${datadir}/user2/*"
73FILES_${PN}-user3 = "${datadir}/user3/*" 73FILES:${PN}-user3 = "${datadir}/user3/*"
74 74
75# Prevents do_package failures with: 75# Prevents do_package failures with:
76# debugsources.list: No such file or directory: 76# debugsources.list: No such file or directory: