diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-07-28 23:28:15 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-08-02 15:44:10 +0100 |
commit | bb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch) | |
tree | 76e376b01253c3aace1a98a5021bcaad3c92e861 /meta-skeleton | |
parent | fcc456ee4b8f619134abb4649db53c638074082c (diff) | |
download | poky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz |
Convert to new override syntax
This is the result of automated script conversion:
scripts/contrib/convert-overrides.py <oe-core directory>
converting the metadata to use ":" as the override character instead of "_".
(From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-skeleton')
8 files changed, 20 insertions, 20 deletions
diff --git a/meta-skeleton/conf/multilib-example.conf b/meta-skeleton/conf/multilib-example.conf index da6da7f1f6..07fd7b6ce4 100644 --- a/meta-skeleton/conf/multilib-example.conf +++ b/meta-skeleton/conf/multilib-example.conf | |||
@@ -10,4 +10,4 @@ | |||
10 | MACHINE = "qemux86-64" | 10 | MACHINE = "qemux86-64" |
11 | require conf/multilib.conf | 11 | require conf/multilib.conf |
12 | MULTILIBS = "multilib:lib32" | 12 | MULTILIBS = "multilib:lib32" |
13 | DEFAULTTUNE_virtclass-multilib-lib32 = "x86" | 13 | DEFAULTTUNE:virtclass-multilib-lib32 = "x86" |
diff --git a/meta-skeleton/conf/multilib-example2.conf b/meta-skeleton/conf/multilib-example2.conf index 2596f61d9f..39f385fcca 100644 --- a/meta-skeleton/conf/multilib-example2.conf +++ b/meta-skeleton/conf/multilib-example2.conf | |||
@@ -10,4 +10,4 @@ | |||
10 | MACHINE = "qemux86-64" | 10 | MACHINE = "qemux86-64" |
11 | require conf/multilib.conf | 11 | require conf/multilib.conf |
12 | MULTILIBS = "multilib:libx32" | 12 | MULTILIBS = "multilib:libx32" |
13 | DEFAULTTUNE_virtclass-multilib-libx32 = "x86-64-x32" | 13 | DEFAULTTUNE:virtclass-multilib-libx32 = "x86-64-x32" |
diff --git a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb index 19ef16988f..37193f5a33 100644 --- a/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb +++ b/meta-skeleton/recipes-baremetal/baremetal-examples/baremetal-helloworld_git.bb | |||
@@ -31,12 +31,12 @@ inherit baremetal-image | |||
31 | COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64|qemuriscv64" | 31 | COMPATIBLE_MACHINE = "qemuarmv5|qemuarm|qemuarm64|qemuriscv64" |
32 | 32 | ||
33 | BAREMETAL_QEMUARCH ?= "" | 33 | BAREMETAL_QEMUARCH ?= "" |
34 | BAREMETAL_QEMUARCH_qemuarmv5 = "versatile" | 34 | BAREMETAL_QEMUARCH:qemuarmv5 = "versatile" |
35 | BAREMETAL_QEMUARCH_qemuarm = "arm" | 35 | BAREMETAL_QEMUARCH:qemuarm = "arm" |
36 | BAREMETAL_QEMUARCH_qemuarm64 = "aarch64" | 36 | BAREMETAL_QEMUARCH:qemuarm64 = "aarch64" |
37 | BAREMETAL_QEMUARCH_qemuriscv64 = "riscv64" | 37 | BAREMETAL_QEMUARCH:qemuriscv64 = "riscv64" |
38 | 38 | ||
39 | EXTRA_OEMAKE_append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1" | 39 | EXTRA_OEMAKE:append = " QEMUARCH=${BAREMETAL_QEMUARCH} V=1" |
40 | 40 | ||
41 | 41 | ||
42 | # Install binaries on the proper location for baremetal-image to fetch and deploy | 42 | # Install binaries on the proper location for baremetal-image to fetch and deploy |
@@ -46,7 +46,7 @@ do_install(){ | |||
46 | install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.elf ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf | 46 | install -m 755 ${B}/build/hello_baremetal_${BAREMETAL_QEMUARCH}.elf ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf |
47 | } | 47 | } |
48 | 48 | ||
49 | FILES_${PN} += " \ | 49 | FILES:${PN} += " \ |
50 | ${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin \ | 50 | ${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin \ |
51 | ${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf \ | 51 | ${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf \ |
52 | " | 52 | " |
diff --git a/meta-skeleton/recipes-core/busybox/busybox_%.bbappend b/meta-skeleton/recipes-core/busybox/busybox_%.bbappend index 5c5e7c356b..621c94f651 100644 --- a/meta-skeleton/recipes-core/busybox/busybox_%.bbappend +++ b/meta-skeleton/recipes-core/busybox/busybox_%.bbappend | |||
@@ -6,8 +6,8 @@ | |||
6 | # | 6 | # |
7 | # More details can be found in the Kernel Dev Manual | 7 | # More details can be found in the Kernel Dev Manual |
8 | # http://www.yoctoproject.org/docs/current/kernel-dev/kernel-dev.html#changing-the-configuration | 8 | # http://www.yoctoproject.org/docs/current/kernel-dev/kernel-dev.html#changing-the-configuration |
9 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 9 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
10 | 10 | ||
11 | SRC_URI_append_mydistro += " \ | 11 | SRC_URI:append:mydistro += " \ |
12 | file://no_rfkill.cfg \ | 12 | file://no_rfkill.cfg \ |
13 | " | 13 | " |
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb index bc9acccd5f..4a84a9fad8 100644 --- a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb +++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb | |||
@@ -15,4 +15,4 @@ S = "${WORKDIR}" | |||
15 | # The inherit of module.bbclass will automatically name module packages with | 15 | # The inherit of module.bbclass will automatically name module packages with |
16 | # "kernel-module-" prefix as required by the oe-core build environment. | 16 | # "kernel-module-" prefix as required by the oe-core build environment. |
17 | 17 | ||
18 | RPROVIDES_${PN} += "kernel-module-hello" | 18 | RPROVIDES:${PN} += "kernel-module-hello" |
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb index d53f9c7a40..6062f8422c 100644 --- a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb +++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb | |||
@@ -57,7 +57,7 @@ require recipes-kernel/linux/linux-yocto.inc | |||
57 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine" | 57 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1;name=machine" |
58 | 58 | ||
59 | LINUX_VERSION ?= "4.2" | 59 | LINUX_VERSION ?= "4.2" |
60 | LINUX_VERSION_EXTENSION_append = "-custom" | 60 | LINUX_VERSION_EXTENSION:append = "-custom" |
61 | 61 | ||
62 | # Modify SRCREV to a different commit hash in a copy of this recipe to | 62 | # Modify SRCREV to a different commit hash in a copy of this recipe to |
63 | # build a different release of the Linux kernel. | 63 | # build a different release of the Linux kernel. |
diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb index 669d173ad1..2c048aa050 100644 --- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb +++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb | |||
@@ -27,6 +27,6 @@ do_install () { | |||
27 | install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/ | 27 | install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/ |
28 | } | 28 | } |
29 | 29 | ||
30 | RDEPENDS_${PN} = "initscripts" | 30 | RDEPENDS:${PN} = "initscripts" |
31 | 31 | ||
32 | CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton" | 32 | CONFFILES:${PN} += "${sysconfdir}/init.d/skeleton" |
diff --git a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb index 7c5b9d0503..3f4c42d714 100644 --- a/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb +++ b/meta-skeleton/recipes-skeleton/useradd/useradd-example.bb | |||
@@ -30,19 +30,19 @@ USERADD_PACKAGES = "${PN} ${PN}-user3" | |||
30 | # useradd command. Multiple users can be created by separating | 30 | # useradd command. Multiple users can be created by separating |
31 | # the commands with a semicolon. Here we'll create two users, | 31 | # the commands with a semicolon. Here we'll create two users, |
32 | # user1 and user2: | 32 | # user1 and user2: |
33 | USERADD_PARAM_${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2" | 33 | USERADD_PARAM:${PN} = "-u 1200 -d /home/user1 -r -s /bin/bash user1; -u 1201 -d /home/user2 -r -s /bin/bash user2" |
34 | 34 | ||
35 | # user3 will be managed in the useradd-example-user3 pacakge: | 35 | # user3 will be managed in the useradd-example-user3 pacakge: |
36 | # As an example, we use the -P option to set clear text password for user3 | 36 | # As an example, we use the -P option to set clear text password for user3 |
37 | USERADD_PARAM_${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3" | 37 | USERADD_PARAM:${PN}-user3 = "-u 1202 -d /home/user3 -r -s /bin/bash -P 'user3' user3" |
38 | 38 | ||
39 | # GROUPADD_PARAM works the same way, which you set to the options | 39 | # GROUPADD_PARAM works the same way, which you set to the options |
40 | # you'd normally pass to the groupadd command. This will create | 40 | # you'd normally pass to the groupadd command. This will create |
41 | # groups group1 and group2: | 41 | # groups group1 and group2: |
42 | GROUPADD_PARAM_${PN} = "-g 880 group1; -g 890 group2" | 42 | GROUPADD_PARAM:${PN} = "-g 880 group1; -g 890 group2" |
43 | 43 | ||
44 | # Likewise, we'll manage group3 in the useradd-example-user3 package: | 44 | # Likewise, we'll manage group3 in the useradd-example-user3 package: |
45 | GROUPADD_PARAM_${PN}-user3 = "-g 900 group3" | 45 | GROUPADD_PARAM:${PN}-user3 = "-g 900 group3" |
46 | 46 | ||
47 | do_install () { | 47 | do_install () { |
48 | install -d -m 755 ${D}${datadir}/user1 | 48 | install -d -m 755 ${D}${datadir}/user1 |
@@ -69,8 +69,8 @@ do_install () { | |||
69 | chgrp -R group3 ${D}${datadir}/user3 | 69 | chgrp -R group3 ${D}${datadir}/user3 |
70 | } | 70 | } |
71 | 71 | ||
72 | FILES_${PN} = "${datadir}/user1/* ${datadir}/user2/*" | 72 | FILES:${PN} = "${datadir}/user1/* ${datadir}/user2/*" |
73 | FILES_${PN}-user3 = "${datadir}/user3/*" | 73 | FILES:${PN}-user3 = "${datadir}/user3/*" |
74 | 74 | ||
75 | # Prevents do_package failures with: | 75 | # Prevents do_package failures with: |
76 | # debugsources.list: No such file or directory: | 76 | # debugsources.list: No such file or directory: |