summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-12-30 19:38:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-31 17:10:21 +0000
commitc9c2b6b613bbaf7133d9c3435f3aef3fe4e38f59 (patch)
tree192a40663b054399ad5f7bf1f30203f9070b6bb1 /meta-selftest/recipes-test/devtool/devtool-test-localonly.bb
parente73119966a0a20c0e380d9f7f5b5ea48feaf7dbb (diff)
downloadpoky-c9c2b6b613bbaf7133d9c3435f3aef3fe4e38f59.tar.gz
devtool: process local files only for the main branch
devtool modify/upgrade are not currently equipped to handle conditional local files in SRC_URI, and provide only the main no-override set in a workspace under source/component/oe-local-files/ (this is done via meta/classes/devtool-source.bbclass). On the other hand, updating the changes from workspace into a recipe is run iteratively against all overrides; this works for patches (as they all are directed into their own override branches in the workspace git source tree), but breaks down when trying to match local files in a workspace against local files in overridden SRC_URI lists, resulting in bad recipe breakage. (there's an additional twist here: existing code has a guard against this but the guard relies on metadata in workspace .bbappend that is only there in modify operations, but not upgrades. This commit replaces the guard with a general check that will work everywhere). Implementing multiple sets of local files is significant work; let's for now simply not touch local files in recipes except when on the no-override variant. Also, adjust the selftest cases to include conditional local files in sample recipes, so the situation is covered by the tests. (From OE-Core rev: 3a8654b860fa98f94e80c3c3fff359ffed14bbe7) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test/devtool/devtool-test-localonly.bb')
-rw-r--r--meta-selftest/recipes-test/devtool/devtool-test-localonly.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb b/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb
index 3f7123cda0..e767619879 100644
--- a/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb
+++ b/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb
@@ -4,4 +4,7 @@ INHIBIT_DEFAULT_DEPS = "1"
4SRC_URI = "file://file1 \ 4SRC_URI = "file://file1 \
5 file://file2" 5 file://file2"
6 6
7SRC_URI:append:class-native = " file://file3"
8
7EXCLUDE_FROM_WORLD = "1" 9EXCLUDE_FROM_WORLD = "1"
10BBCLASSEXTEND = "native"