diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2022-12-30 19:38:50 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-12-31 17:10:21 +0000 |
commit | c9c2b6b613bbaf7133d9c3435f3aef3fe4e38f59 (patch) | |
tree | 192a40663b054399ad5f7bf1f30203f9070b6bb1 /meta-selftest | |
parent | e73119966a0a20c0e380d9f7f5b5ea48feaf7dbb (diff) | |
download | poky-c9c2b6b613bbaf7133d9c3435f3aef3fe4e38f59.tar.gz |
devtool: process local files only for the main branch
devtool modify/upgrade are not currently equipped to handle conditional local files
in SRC_URI, and provide only the main no-override set in a workspace under
source/component/oe-local-files/ (this is done via meta/classes/devtool-source.bbclass).
On the other hand, updating the changes from workspace into a recipe
is run iteratively against all overrides; this works for patches (as they
all are directed into their own override branches in the workspace
git source tree), but breaks down when trying to match local files
in a workspace against local files in overridden SRC_URI lists, resulting in
bad recipe breakage.
(there's an additional twist here: existing code has a guard against this
but the guard relies on metadata in workspace .bbappend that is only there
in modify operations, but not upgrades. This commit replaces the guard
with a general check that will work everywhere).
Implementing multiple sets of local files is significant work; let's for now
simply not touch local files in recipes except when on the no-override variant.
Also, adjust the selftest cases to include conditional local files in sample
recipes, so the situation is covered by the tests.
(From OE-Core rev: 3a8654b860fa98f94e80c3c3fff359ffed14bbe7)
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest')
4 files changed, 8 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/devtool/devtool-test-local/file3 b/meta-selftest/recipes-test/devtool/devtool-test-local/file3 new file mode 100644 index 0000000000..0f30e9eec4 --- /dev/null +++ b/meta-selftest/recipes-test/devtool/devtool-test-local/file3 | |||
@@ -0,0 +1 @@ | |||
The third file. | |||
diff --git a/meta-selftest/recipes-test/devtool/devtool-test-local_6.03.bb b/meta-selftest/recipes-test/devtool/devtool-test-local_6.03.bb index 463cfe0a7a..d0fd697978 100644 --- a/meta-selftest/recipes-test/devtool/devtool-test-local_6.03.bb +++ b/meta-selftest/recipes-test/devtool/devtool-test-local_6.03.bb | |||
@@ -7,9 +7,12 @@ SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/syslinux-${PV}.tar.x | |||
7 | file://file1 \ | 7 | file://file1 \ |
8 | file://file2" | 8 | file://file2" |
9 | 9 | ||
10 | SRC_URI:append:class-native = " file://file3" | ||
11 | |||
10 | SRC_URI[md5sum] = "92a253df9211e9c20172796ecf388f13" | 12 | SRC_URI[md5sum] = "92a253df9211e9c20172796ecf388f13" |
11 | SRC_URI[sha256sum] = "26d3986d2bea109d5dc0e4f8c4822a459276cf021125e8c9f23c3cca5d8c850e" | 13 | SRC_URI[sha256sum] = "26d3986d2bea109d5dc0e4f8c4822a459276cf021125e8c9f23c3cca5d8c850e" |
12 | 14 | ||
13 | S = "${WORKDIR}/syslinux-${PV}" | 15 | S = "${WORKDIR}/syslinux-${PV}" |
14 | 16 | ||
15 | EXCLUDE_FROM_WORLD = "1" | 17 | EXCLUDE_FROM_WORLD = "1" |
18 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb b/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb index 3f7123cda0..e767619879 100644 --- a/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb +++ b/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb | |||
@@ -4,4 +4,7 @@ INHIBIT_DEFAULT_DEPS = "1" | |||
4 | SRC_URI = "file://file1 \ | 4 | SRC_URI = "file://file1 \ |
5 | file://file2" | 5 | file://file2" |
6 | 6 | ||
7 | SRC_URI:append:class-native = " file://file3" | ||
8 | |||
7 | EXCLUDE_FROM_WORLD = "1" | 9 | EXCLUDE_FROM_WORLD = "1" |
10 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-selftest/recipes-test/devtool/devtool-test-localonly/file3 b/meta-selftest/recipes-test/devtool/devtool-test-localonly/file3 new file mode 100644 index 0000000000..0f30e9eec4 --- /dev/null +++ b/meta-selftest/recipes-test/devtool/devtool-test-localonly/file3 | |||
@@ -0,0 +1 @@ | |||
The third file. | |||