summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-11-05 17:36:00 +0000
committerRoss Burton <ross@openedhand.com>2007-11-05 17:36:00 +0000
commit7676c2b38e649b294bc1332839b3c3a26489dd34 (patch)
tree6de7024701603e068251830108c09954ef36db4b /meta-extras
parent2188cf09e11398447a6e59ee8a2819877f90b45c (diff)
downloadpoky-7676c2b38e649b294bc1332839b3c3a26489dd34.tar.gz
Move ubootchart to meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3072 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/ubootchart/files/pass-args.patch21
-rw-r--r--meta-extras/packages/ubootchart/files/sysvinit.patch12
-rw-r--r--meta-extras/packages/ubootchart/files/ubootchart-stop3
-rw-r--r--meta-extras/packages/ubootchart/files/ubootchart.desktop6
-rw-r--r--meta-extras/packages/ubootchart/ubootchart_svn.bb38
5 files changed, 0 insertions, 80 deletions
diff --git a/meta-extras/packages/ubootchart/files/pass-args.patch b/meta-extras/packages/ubootchart/files/pass-args.patch
deleted file mode 100644
index 9ad4282f21..0000000000
--- a/meta-extras/packages/ubootchart/files/pass-args.patch
+++ /dev/null
@@ -1,21 +0,0 @@
1Index: ubootchartd
2===================================================================
3--- ubootchartd (revision 9)
4+++ ubootchartd (working copy)
5@@ -7,9 +7,11 @@
6 # can read.
7 . /etc/ubootchart/ubootchart.conf
8
9-####################################################
10-# Now start capturing the stats:
11-####################################################
12-/sbin/ubootchartd_bin &
13-exec $init_prog
14+if [ $$ -eq 1 ]; then
15+ ####################################################
16+ # Now start capturing the stats:
17+ ####################################################
18+ /sbin/ubootchartd_bin &
19+fi
20
21+exec $init_prog "$@"
diff --git a/meta-extras/packages/ubootchart/files/sysvinit.patch b/meta-extras/packages/ubootchart/files/sysvinit.patch
deleted file mode 100644
index de9fb0b17d..0000000000
--- a/meta-extras/packages/ubootchart/files/sysvinit.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1Index: ubootchart.conf
2===================================================================
3--- ubootchart.conf (revision 9)
4+++ ubootchart.conf (working copy)
5@@ -1,6 +1,6 @@
6
7 # If you want to chain on and run somthing other than /sbin/init...
8-export init_prog=/sbin/init
9+export init_prog=/sbin/init.sysvinit
10
11 # On startup ubootchart will mount a tmpfs filesystem at this
12 # location and chdir here. This is only used for the logging of
diff --git a/meta-extras/packages/ubootchart/files/ubootchart-stop b/meta-extras/packages/ubootchart/files/ubootchart-stop
deleted file mode 100644
index 3444069c9a..0000000000
--- a/meta-extras/packages/ubootchart/files/ubootchart-stop
+++ /dev/null
@@ -1,3 +0,0 @@
1#! /bin/sh
2
3kill -USR1 $(pidof ubootchartd_bin)
diff --git a/meta-extras/packages/ubootchart/files/ubootchart.desktop b/meta-extras/packages/ubootchart/files/ubootchart.desktop
deleted file mode 100644
index 5552b3bc6f..0000000000
--- a/meta-extras/packages/ubootchart/files/ubootchart.desktop
+++ /dev/null
@@ -1,6 +0,0 @@
1[Desktop Entry]
2Encoding=UTF-8
3Exec=/sbin/ubootchart-stop
4Name=Stop Bootchart
5Type=Application
6Categories=Programming;
diff --git a/meta-extras/packages/ubootchart/ubootchart_svn.bb b/meta-extras/packages/ubootchart/ubootchart_svn.bb
deleted file mode 100644
index 7ab485c58c..0000000000
--- a/meta-extras/packages/ubootchart/ubootchart_svn.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1DESCRIPTION = "A boot profiling tool"
2HOMEPAGE = "http://code.google.com/p/ubootchart/"
3LICENSE = "GPLv3"
4PV = "0.0+r${SRCREV}"
5PR = "r2"
6
7RRECOMMENDS = "acct"
8
9SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
10 file://sysvinit.patch;patch=1;pnum=0 \
11 file://pass-args.patch;patch=1;pnum=0 \
12 file://ubootchart-stop \
13 file://ubootchart.desktop"
14
15S = "${WORKDIR}/trunk"
16
17inherit update-alternatives
18
19ALTERNATIVE_NAME = "init"
20ALTERNATIVE_LINK = "${base_sbindir}/init"
21ALTERNATIVE_PATH = "${base_sbindir}/ubootchartd"
22ALTERNATIVE_PRIORITY = "20"
23
24do_compile() {
25 ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
26}
27
28do_install() {
29 install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}/usr/share/applications
30 install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
31 install -m 0755 ${S}/ubootchartd ${D}/sbin
32 install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
33 install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
34 install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
35
36 install -m 0755 ${WORKDIR}/ubootchart-stop ${D}/sbin
37 install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}/usr/share/applications
38}