summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/ubootchart/ubootchart_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/ubootchart/ubootchart_svn.bb')
-rw-r--r--meta-extras/packages/ubootchart/ubootchart_svn.bb38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-extras/packages/ubootchart/ubootchart_svn.bb b/meta-extras/packages/ubootchart/ubootchart_svn.bb
deleted file mode 100644
index 7ab485c58c..0000000000
--- a/meta-extras/packages/ubootchart/ubootchart_svn.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1DESCRIPTION = "A boot profiling tool"
2HOMEPAGE = "http://code.google.com/p/ubootchart/"
3LICENSE = "GPLv3"
4PV = "0.0+r${SRCREV}"
5PR = "r2"
6
7RRECOMMENDS = "acct"
8
9SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
10 file://sysvinit.patch;patch=1;pnum=0 \
11 file://pass-args.patch;patch=1;pnum=0 \
12 file://ubootchart-stop \
13 file://ubootchart.desktop"
14
15S = "${WORKDIR}/trunk"
16
17inherit update-alternatives
18
19ALTERNATIVE_NAME = "init"
20ALTERNATIVE_LINK = "${base_sbindir}/init"
21ALTERNATIVE_PATH = "${base_sbindir}/ubootchartd"
22ALTERNATIVE_PRIORITY = "20"
23
24do_compile() {
25 ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
26}
27
28do_install() {
29 install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart ${D}/usr/share/applications
30 install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
31 install -m 0755 ${S}/ubootchartd ${D}/sbin
32 install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
33 install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
34 install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
35
36 install -m 0755 ${WORKDIR}/ubootchart-stop ${D}/sbin
37 install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}/usr/share/applications
38}