summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-experimental')
-rw-r--r--meta-xilinx-standalone-experimental/conf/layer.conf2
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend10
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend4
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend10
4 files changed, 17 insertions, 9 deletions
diff --git a/meta-xilinx-standalone-experimental/conf/layer.conf b/meta-xilinx-standalone-experimental/conf/layer.conf
index 8667a166..6cfd01c3 100644
--- a/meta-xilinx-standalone-experimental/conf/layer.conf
+++ b/meta-xilinx-standalone-experimental/conf/layer.conf
@@ -22,7 +22,7 @@ LAYERDEPENDS_xilinx-standalone-exp = "core \
22 virtualization-layer \ 22 virtualization-layer \
23 " 23 "
24 24
25LAYERSERIES_COMPAT_xilinx-standalone-exp = "nanbield" 25LAYERSERIES_COMPAT_xilinx-standalone-exp = "scarthgap"
26 26
27# Aid debugging, show where the device trees are we are using 27# Aid debugging, show where the device trees are we are using
28BUILDCFG_VARS:append = " SYSTEM_DTFILE CONFIG_DTFILE" 28BUILDCFG_VARS:append = " SYSTEM_DTFILE CONFIG_DTFILE"
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
index cc6d757f..202764ac 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
@@ -17,8 +17,14 @@ do_configure:prepend() {
17 ) 17 )
18} 18}
19 19
20do_compile:append() { 20do_configure() {
21 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 21 cmake_do_configure
22}
23
24do_compile() {
25 cmake_do_compile
26
27 ${OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
22} 28}
23 29
24do_install() { 30do_install() {
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
index b5908d46..0c51fbad 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/pmu-firmware_git.bbappend
@@ -18,10 +18,6 @@ do_configure:prepend() {
18 ) 18 )
19} 19}
20 20
21do_compile:append() {
22 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
23}
24
25do_install() { 21do_install() {
26 : 22 :
27} 23}
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
index c4953ce7..96cd38cd 100644
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
+++ b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/psm-firmware_git.bbappend
@@ -17,8 +17,14 @@ do_configure:prepend() {
17 ) 17 )
18} 18}
19 19
20do_compile:append() { 20do_configure() {
21 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin 21 cmake_do_configure
22}
23
24do_compile() {
25 cmake_do_compile
26
27 ${OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
22} 28}
23 29
24do_install() { 30do_install() {