summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend')
-rw-r--r--meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend28
1 files changed, 0 insertions, 28 deletions
diff --git a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend b/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
deleted file mode 100644
index cc6d757f..00000000
--- a/meta-xilinx-standalone-experimental/recipes-bsp/embeddedsw/plm-firmware_git.bbappend
+++ /dev/null
@@ -1,28 +0,0 @@
1# We WANT to default to this version when available
2DEFAULT_PREFERENCE = "100"
3
4# Reset this
5SRC_URI = "${EMBEDDEDSW_SRCURI}"
6
7inherit esw
8
9ESW_COMPONENT_SRC = "/lib/sw_apps/versal_plm/src/"
10
11ESW_COMPONENT = "versal_plm.elf"
12
13do_configure:prepend() {
14 (
15 cd ${S}
16 install -m 0644 ${S}/cmake/UserConfig.cmake ${S}/${ESW_COMPONENT_SRC}
17 )
18}
19
20do_compile:append() {
21 ${MB_OBJCOPY} -O binary ${B}/${ESW_COMPONENT} ${B}/${ESW_COMPONENT}.bin
22}
23
24do_install() {
25 :
26}
27
28DEPENDS += "xilstandalone xiltimer xilffs xilpdi xilplmi xilloader xilpm xilsecure xilsem xilnvm"