summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-devtools')
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc5
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees_2022.1.bb3
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees_2022.2.bb6
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb31
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-native_2022.2.bb7
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb2
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb20
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc13
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2022.2.bb17
9 files changed, 64 insertions, 40 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc
index 87d90a50..b08b414f 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees.inc
@@ -7,10 +7,7 @@ inherit deploy
7 7
8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99" 8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99"
9 9
10PV = "xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" 10PV = "xilinx-v${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[1] or ''}+git${SRCPV}"
11
12FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
13SRC_URI:append = " file://0001-Makefile-Use-python3-instead-of-python.patch"
14 11
15REPO ?= "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https" 12REPO ?= "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https"
16 13
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees_2022.1.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees_2022.1.bb
index e2f134fe..7c734cd6 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees_2022.1.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees_2022.1.bb
@@ -3,3 +3,6 @@ require qemu-devicetrees.inc
3 3
4BRANCH ?= "xlnx_rel_v2022.1" 4BRANCH ?= "xlnx_rel_v2022.1"
5SRCREV ?= "0499324af1178057c3730b0989c8fb5c5bbc4cf8" 5SRCREV ?= "0499324af1178057c3730b0989c8fb5c5bbc4cf8"
6
7FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
8SRC_URI:append = " file://0001-Makefile-Use-python3-instead-of-python.patch"
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees_2022.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees_2022.2.bb
new file mode 100644
index 00000000..c7719866
--- /dev/null
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-devicetrees_2022.2.bb
@@ -0,0 +1,6 @@
1
2require qemu-devicetrees.inc
3
4BRANCH ?= "master"
5SRCREV ?= "42d0b7e24fbd1adc72fb2d0e70e06ff332278468"
6
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
index 2450d275..dd47f7a7 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
@@ -1,36 +1,13 @@
1FILESEXTRAPATHS:prepend := "${COREBASE}/meta/recipes-devtools/qemu/qemu-helper:" 1FILESEXTRAPATHS:prepend := "${COREBASE}/meta/recipes-devtools/qemu/qemu-helper:"
2 2
3# provide it, to replace the existing 3require ${COREBASE}/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
4PROVIDES = "qemu-helper-native"
5PR = "r1"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999"
9
10SRC_URI = "\
11 file://tunctl.c \
12 "
13
14S = "${WORKDIR}"
15 4
16inherit native 5# provide it, to replace the existing recipe
6PROVIDES = "qemu-helper-native"
17 7
18do_compile() {
19 ${CC} ${CFLAGS} ${LDFLAGS} -Wall tunctl.c -o tunctl
20}
21# replace qemu with qemu-xilinx 8# replace qemu with qemu-xilinx
22DEPENDS:remove = "qemu-system-native" 9DEPENDS:remove = "qemu-system-native"
23DEPENDS:append = " \ 10DEPENDS:append = " qemu-xilinx-system-native qemu-xilinx-multiarch-helper-native"
24 qemu-xilinx-system-native \
25 qemu-xilinx-multiarch-helper-native \
26 "
27 11
28RDEPENDS:${PN}:remove = "qemu-system-native" 12RDEPENDS:${PN}:remove = "qemu-system-native"
29RDEPENDS:${PN}:append = " qemu-xilinx-system-native" 13RDEPENDS:${PN}:append = " qemu-xilinx-system-native"
30
31do_install() {
32 install -d ${STAGING_BINDIR_NATIVE}
33 install tunctl ${STAGING_BINDIR_NATIVE}
34
35}
36addtask addto_recipe_sysroot after do_populate_sysroot before do_build
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-native_2022.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-native_2022.2.bb
new file mode 100644
index 00000000..5e6c2d28
--- /dev/null
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-native_2022.2.bb
@@ -0,0 +1,7 @@
1require qemu-xilinx-native.inc
2BPN = "qemu-xilinx"
3
4EXTRA_OECONF:append = " --target-list=${@get_qemu_usermode_target_list(d)} --disable-tools --disable-blobs --disable-guest-agent"
5
6PROVIDES = "qemu-native"
7PACKAGECONFIG ??= "pie"
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb
index f177872a..49faa73c 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.1.bb
@@ -4,7 +4,7 @@ PROVIDES = "qemu-system-native"
4 4
5EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}" 5EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
6 6
7PACKAGECONFIG ??= "fdt alsa kvm pie" 7PACKAGECONFIG ??= "fdt alsa kvm pie slirp"
8 8
9PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" 9PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
10 10
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb
new file mode 100644
index 00000000..49faa73c
--- /dev/null
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-system-native_2022.2.bb
@@ -0,0 +1,20 @@
1require qemu-xilinx-native.inc
2
3PROVIDES = "qemu-system-native"
4
5EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
6
7PACKAGECONFIG ??= "fdt alsa kvm pie slirp"
8
9PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
10
11DEPENDS += "pixman-native qemu-xilinx-native bison-native ninja-native meson-native"
12
13do_install:append() {
14 # The following is also installed by qemu-native
15 rm -f ${D}${datadir}/qemu/trace-events-all
16 rm -rf ${D}${datadir}/qemu/keymaps
17 rm -rf ${D}${datadir}/icons
18 rm -rf ${D}${includedir}/qemu-plugin.h
19}
20
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc
index d42aa484..48b85f21 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx.inc
@@ -11,12 +11,12 @@ LIC_FILES_CHKSUM = " \
11DEPENDS = "glib-2.0 zlib pixman bison-native ninja-native meson-native" 11DEPENDS = "glib-2.0 zlib pixman bison-native ninja-native meson-native"
12 12
13XILINX_QEMU_VERSION ?= "v6.1.0" 13XILINX_QEMU_VERSION ?= "v6.1.0"
14BRANCH ?= "xlnx_rel_v2022.1" 14BRANCH ?= "master"
15SRCREV = "52a9b22faeb149a6b17646b1f912f06ea6c269ca" 15SRCREV = "fbcb55665e9f5f91110ba2a44f62be9bc72752ee"
16 16
17FILESEXTRAPATHS:prepend := "${THISDIR}/files:" 17FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
18 18
19PV = "${XILINX_QEMU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" 19PV = "${XILINX_QEMU_VERSION}-xilinx-v${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[1] or ''}+git${SRCPV}"
20REPO ?= "gitsm://github.com/Xilinx/qemu.git;protocol=https" 20REPO ?= "gitsm://github.com/Xilinx/qemu.git;protocol=https"
21 21
22BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" 22BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
@@ -28,19 +28,16 @@ S = "${WORKDIR}/git"
28 28
29# Disable KVM completely 29# Disable KVM completely
30PACKAGECONFIG:remove = "kvm" 30PACKAGECONFIG:remove = "kvm"
31PACKAGECONFIG:append = " fdt sdl gcrypt pie" 31PACKAGECONFIG:append = " fdt sdl gcrypt pie slirp"
32 32
33 33
34PACKAGECONFIG[gcrypt] = "--enable-gcrypt,--disable-gcrypt,libgcrypt,"
35PACKAGECONFIG[sdl] = "--enable-sdl,--disable-sdl,libsdl2"
36PACKAGECONFIG[pie] = "--enable-pie,--disable-pie,,"
37
38# Remove when version is in sync with core oe-core 34# Remove when version is in sync with core oe-core
39PACKAGECONFIG:remove:class-nativesdk= "pulsedio" 35PACKAGECONFIG:remove:class-nativesdk= "pulsedio"
40PACKAGECONFIG:remove:class-native = "pulsedio" 36PACKAGECONFIG:remove:class-native = "pulsedio"
41PACKAGECONFIG[alsa] = "--audio-drv-list=alsa,,alsa-lib" 37PACKAGECONFIG[alsa] = "--audio-drv-list=alsa,,alsa-lib"
42PACKAGECONFIG[pulsedio] = "--audio-drv-list=pa,,pulseaudio" 38PACKAGECONFIG[pulsedio] = "--audio-drv-list=pa,,pulseaudio"
43PACKAGECONFIG[selinux] = "" 39PACKAGECONFIG[selinux] = ""
40PACKAGECONFIG[slirp] = "--enable-slirp=git,--disable-slirp,,"
44 41
45DISABLE_STATIC:pn-${PN} = "" 42DISABLE_STATIC:pn-${PN} = ""
46 43
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2022.2.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2022.2.bb
new file mode 100644
index 00000000..4983b4df
--- /dev/null
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx_2022.2.bb
@@ -0,0 +1,17 @@
1require recipes-devtools/qemu/qemu.inc
2require qemu-xilinx.inc
3
4BBCLASSEXTEND = "nativesdk"
5
6RDEPENDS:${PN}:class-target += "bash"
7
8PROVIDES:class-nativesdk = "nativesdk-qemu"
9RPROVIDES:${PN}:class-nativesdk = "nativesdk-qemu"
10
11EXTRA_OECONF:append:class-target = " --target-list=${@get_qemu_target_list(d)}"
12EXTRA_OECONF:append:class-nativesdk = " --target-list=${@get_qemu_target_list(d)}"
13EXTRA_OECONF:append:class-target:mipsarcho32 = "${@bb.utils.contains('BBEXTENDCURR', 'multilib', ' --disable-capstone', '', d)}"
14
15do_install:append:class-nativesdk() {
16 ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)}
17}