summaryrefslogtreecommitdiffstats
path: root/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb')
-rw-r--r--meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb31
1 files changed, 4 insertions, 27 deletions
diff --git a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
index 2450d275..dd47f7a7 100644
--- a/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
+++ b/meta-xilinx-core/recipes-devtools/qemu/qemu-xilinx-helper-native_1.0.bb
@@ -1,36 +1,13 @@
1FILESEXTRAPATHS:prepend := "${COREBASE}/meta/recipes-devtools/qemu/qemu-helper:" 1FILESEXTRAPATHS:prepend := "${COREBASE}/meta/recipes-devtools/qemu/qemu-helper:"
2 2
3# provide it, to replace the existing 3require ${COREBASE}/meta/recipes-devtools/qemu/qemu-helper-native_1.0.bb
4PROVIDES = "qemu-helper-native"
5PR = "r1"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5d4e0b4c28f999"
9
10SRC_URI = "\
11 file://tunctl.c \
12 "
13
14S = "${WORKDIR}"
15 4
16inherit native 5# provide it, to replace the existing recipe
6PROVIDES = "qemu-helper-native"
17 7
18do_compile() {
19 ${CC} ${CFLAGS} ${LDFLAGS} -Wall tunctl.c -o tunctl
20}
21# replace qemu with qemu-xilinx 8# replace qemu with qemu-xilinx
22DEPENDS:remove = "qemu-system-native" 9DEPENDS:remove = "qemu-system-native"
23DEPENDS:append = " \ 10DEPENDS:append = " qemu-xilinx-system-native qemu-xilinx-multiarch-helper-native"
24 qemu-xilinx-system-native \
25 qemu-xilinx-multiarch-helper-native \
26 "
27 11
28RDEPENDS:${PN}:remove = "qemu-system-native" 12RDEPENDS:${PN}:remove = "qemu-system-native"
29RDEPENDS:${PN}:append = " qemu-xilinx-system-native" 13RDEPENDS:${PN}:append = " qemu-xilinx-system-native"
30
31do_install() {
32 install -d ${STAGING_BINDIR_NATIVE}
33 install tunctl ${STAGING_BINDIR_NATIVE}
34
35}
36addtask addto_recipe_sysroot after do_populate_sysroot before do_build