summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-11-30 13:46:24 -0800
committerManjukumar Matha <manjukumar.harthikote-matha@xilinx.com>2017-12-02 18:05:15 -0800
commit82ac762e83e37e45db3fbe38ad1e21114a3426b6 (patch)
treea9289eb477154c52696cf04efde41a69d2a7fc4c /recipes-devtools
parent18971a81a298e87736e162823a40cfd9b0a999fb (diff)
downloadmeta-xilinx-82ac762e83e37e45db3fbe38ad1e21114a3426b6.tar.gz
qemu-devicetrees_2017.3.bb: Rewire QEMU devicetree recipe
Rewire so that we can update the Xilinx QEMU devicetree release just like other recipes Acked-by: Alistair Francis <alistair.francis@xilinx.com> Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-devicetrees.inc37
-rw-r--r--recipes-devtools/qemu/qemu-devicetrees_2017.3.bb34
2 files changed, 40 insertions, 31 deletions
diff --git a/recipes-devtools/qemu/qemu-devicetrees.inc b/recipes-devtools/qemu/qemu-devicetrees.inc
new file mode 100644
index 00000000..d4044ed7
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-devicetrees.inc
@@ -0,0 +1,37 @@
1SUMMARY = "Xilinx's hardware device trees required for QEMU"
2HOMEPAGE = "https://github.com/xilinx/qemu-devicetrees/"
3LICENSE = "BSD"
4DEPENDS += "dtc-native"
5
6inherit deploy
7
8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99"
9
10PV = "xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}"
11
12BRANCH ?= ""
13REPO ?= "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https"
14
15BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
16SRC_URI = "${REPO};${BRANCHARG}"
17
18S = "${WORKDIR}/git"
19
20# Don't need to do anything
21do_install() {
22 :
23}
24
25do_deploy() {
26 # single-arch dtbs
27 for DTS_FILE in ${S}/LATEST/SINGLE_ARCH/*.dtb; do
28 install -Dm 0644 $DTS_FILE ${DEPLOYDIR}/qemu-hw-devicetrees/$(basename $DTS_FILE .dtb).dtb
29 done
30
31 # multi-arch dtbs
32 for DTS_FILE in ${S}/LATEST/MULTI_ARCH/*.dtb; do
33 install -Dm 0644 $DTS_FILE ${DEPLOYDIR}/qemu-hw-devicetrees/multiarch/$(basename $DTS_FILE .dtb).dtb
34 done
35}
36
37addtask deploy after do_install
diff --git a/recipes-devtools/qemu/qemu-devicetrees_2017.3.bb b/recipes-devtools/qemu/qemu-devicetrees_2017.3.bb
index d5cfe0b0..ec6093b7 100644
--- a/recipes-devtools/qemu/qemu-devicetrees_2017.3.bb
+++ b/recipes-devtools/qemu/qemu-devicetrees_2017.3.bb
@@ -1,32 +1,4 @@
1SUMMARY = "Xilinx's hardware device trees required for QEMU" 1require qemu-devicetrees.inc
2HOMEPAGE = "https://github.com/xilinx/qemu-devicetrees/"
3LICENSE = "BSD"
4DEPENDS += "dtc-native"
5 2
6inherit deploy 3XILINX_RELEASE_VERSION = "v2017.3"
7 4SRCREV ?= "4b951c594078562e9dd828430075968dd91ac425"
8LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=27;md5=7348b6cbcae69912cb1dee68d6c68d99"
9
10SRCREV = "4b951c594078562e9dd828430075968dd91ac425"
11SRC_URI = "git://github.com/Xilinx/qemu-devicetrees.git;protocol=https;nobranch=1"
12
13S = "${WORKDIR}/git"
14
15# Don't need to do anything
16do_install() {
17 :
18}
19
20do_deploy() {
21 # single-arch dtbs
22 for DTS_FILE in ${S}/LATEST/SINGLE_ARCH/*.dtb; do
23 install -Dm 0644 $DTS_FILE ${DEPLOYDIR}/qemu-hw-devicetrees/$(basename $DTS_FILE .dtb).dtb
24 done
25
26 # multi-arch dtbs
27 for DTS_FILE in ${S}/LATEST/MULTI_ARCH/*.dtb; do
28 install -Dm 0644 $DTS_FILE ${DEPLOYDIR}/qemu-hw-devicetrees/multiarch/$(basename $DTS_FILE .dtb).dtb
29 done
30}
31
32addtask deploy after do_install